Bug #41128 Unknown Exception caught - Unknown source
Submitted: 30 Nov 2008 3:20 Modified: 17 Dec 2008 17:48
Reporter: Tercio F. Gaudencio Filho Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.0.27 OSS Rev. 3318 OS:Microsoft Windows (XP SP2)
Assigned to: CPU Architecture:Any
Tags: Unknown Exception caught

[30 Nov 2008 3:20] Tercio F. Gaudencio Filho
Description:
I'm doing a diagram for a while.

Now, my diagram random crash.

The crash happens when I try to select some tables, just selecting then crash. I tried to export the diagram to SQL and then import as a new, but after some modifications it get corrupted again.

Shows me this:

"Unknown Exception caught in c:\documents and settings\mysqldev\my documents\visual studio 2005\projects\workbench\backend\windows\wb.wr\src\Wb.h at line 1010"

And if I try to close the diagram it shows me:

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at wb.WBContextUI.set_active_form(WBContextUI* , UIForm* )
   at MySQL.Workbench.WbContext.set_active_form(UIForm uiform)
   at MySQL.GUI.Workbench.MainForm.mainDockPanel_ActiveDocumentChanged(Object sender, EventArgs e)
   at WeifenLuo.WinFormsUI.Docking.DockPanel.OnActiveDocumentChanged(EventArgs e)
   at WeifenLuo.WinFormsUI.Docking.DockPanel.FocusManagerImpl.RefreshActiveWindow()
   at WeifenLuo.WinFormsUI.Docking.DockPanel.FocusManagerImpl.ResumeFocusTracking()
   at WeifenLuo.WinFormsUI.Docking.DockPanel.ResumeLayout(Boolean performLayout, Boolean allWindows)
   at WeifenLuo.WinFormsUI.Docking.DockContentHandler.Close()
   at MySQL.GUI.Workbench.MainForm.MainForm_FormClosing(Object sender, FormClosingEventArgs e)
   at System.Windows.Forms.Form.OnFormClosing(FormClosingEventArgs e)
   at System.Windows.Forms.Form.WmClose(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
MySQLWorkbench
    Assembly Version: 5.0.27.3318
    Win32 Version: 5.0.27.3318
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/MySQLWorkbench.exe
----------------------------------------
wb.wr
    Assembly Version: 0.0.0.0
    Win32 Version: 
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/wb.wr.DLL
----------------------------------------
grt.wr
    Assembly Version: 0.0.0.0
    Win32 Version: 
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/grt.wr.DLL
----------------------------------------
System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
MySQLCsUtilities
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/MySQLCsUtilities.DLL
----------------------------------------
msvcm80
    Assembly Version: 8.0.50727.762
    Win32 Version: 8.00.50727.762
    CodeBase: file:///C:/WINDOWS/WinSxS/x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.762_x-ww_6b128700/msvcm80.dll
----------------------------------------
MySQLGrtShell
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/MySQLGrtShell.EXE
----------------------------------------
WeifenLuo.WinFormsUI.Docking
    Assembly Version: 2.2.3232.43134
    Win32 Version: 2.2.0.0
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/WeifenLuo.WinFormsUI.Docking.DLL
----------------------------------------
System.Configuration
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
MySQLWorkbenchEditors
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/MySQLWorkbenchEditors.DLL
----------------------------------------
Aga.Controls
    Assembly Version: 1.6.0.0
    Win32 Version: 1.6.0.0
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/Aga.Controls.DLL
----------------------------------------
grt.helpers.be
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/grt.helpers.be.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

How to repeat:
Only with my diagram I could repeat this bug.
[30 Nov 2008 19:37] Miguel Solorzano
Thank you for the bug report. Could you please provide the output of Help->System Info?. Thanks in advance.
[1 Dec 2008 18:18] Tercio F. Gaudencio Filho
Just for information, I'm running on VMWare Fusion 2.1.

I tried with and without the 3d Rendering enabled.

Looking for user plugins in C:\Documents and Settings\Administrator\Application Data\MySQL\Workbench\modules
Looking for user plugins in C:\Documents and Settings\Administrator\Application Data\MySQL\Workbench\plugins
MySQL Workbench OSS for Windows version 5.0.27
Cairo Version: 1.5.12
Rendering Mode: GDI Rendering
OpenGL Driver Version: Not Detected
OS: Windows XP
CPU: Intel(R) Core(TM)2 CPU         T7400  @ 2.16GHz, 0.8 GB RAM
Video adapter info:
Adapter type: VMware SVGA II
Chip Type: VMware SVGA II
BIOS String: VMware SVGA II
Video Memory: 131072 KB
[3 Dec 2008 14:21] Susanne Ebrecht
Many thanks for writing a bug report. This is not repeatable for us.

Do you have this crash only by using always the same diagram or do you have it with different diagrams?
[3 Dec 2008 15:40] Tercio F. Gaudencio Filho
I tried to export the diagram to SQL, and the import it as a new diagram. But no success, it crash same way.

What else can I do? Some kind of debug...?
[3 Dec 2008 15:44] Tercio F. Gaudencio Filho
I will try to reproduce with other diagram....
[3 Dec 2008 15:56] Susanne Ebrecht
try it with total different diagramms. With new diagramms that you created.
[5 Dec 2008 1:46] Tercio F. Gaudencio Filho
Hi,

I tried with another diagram that I created, and the same problem. I created this diagram from zero.

In my computer it seems to run slow, and it "freezes" when I performe some action(Like edit table fields).

I think that some overlap actions maybe causing this.
[9 Dec 2008 7:27] Valeriy Kravchuk
Please, try to repeat with a newer version, 5.0.28, and inform about the results.
[17 Dec 2008 17:48] Tercio F. Gaudencio Filho
This problem persists with the last version and other diagrams.

It seems to be related to the VMWare Fusion 2.0.

For some reason the video driver has some kind of bug with MySQL Workbench.

With Parallels 4.0 this problem doesn't occur.

I'll consider this bug closed, as it doesn't depends of MySQL Workbench team.

Just for future reference:

Hardware Overview:
  Model Name:	MacBook
  Model Identifier:	MacBook2,1
  Processor Name:	Intel Core 2 Duo
  Processor Speed:	2.16 GHz
  Number Of Processors:	1
  Total Number Of Cores:	2
  L2 Cache:	4 MB
  Memory:	3 GB
  Bus Speed:	667 MHz
  Boot ROM Version:	MB21.00A5.B07
  SMC Version:	1.17f0
  Sudden Motion Sensor:
  State:	Enabled

VMware Fusion 2.0.1 build: 128865