Bug #41125 phpBB install script could not be runned
Submitted: 29 Nov 2008 15:53 Modified: 29 Nov 2008 17:37
Reporter: Camilo Peuela Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: General Severity:S2 (Serious)
Version:6.0 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: key, long, php, phpBB

[29 Nov 2008 15:53] Camilo Peuela
Description:
The phpBB install script could not be runned, this is the error message from mysql (latest stable version on november 8,2008):

A fatal and unrecoverable database error has occurred. This may be because the specified user does not have appropriate permissions to CREATE TABLES or INSERT data, etc. Further information may be given below. Please contact your hosting provider in the first instance or the support forums of phpBB for further assistance.

install_install.php [ 1194 ]

SQL : CREATE TABLE phpbb_config ( config_name varchar(255) DEFAULT '' NOT NULL,
config_value varchar(255) DEFAULT '' NOT NULL, is_dynamic tinyint(1) UNSIGNED DEFAULT '0'
NOT NULL, PRIMARY KEY (config_name), KEY is_dynamic (is_dynamic) ) CHARACTER SET `utf8`
COLLATE `utf8_bin`

Specified key was too long; max key length is 767 bytes

It is obvious that the mysql user has all the required permissions.

This problem is posted at phpBB forums, but this is a bug of mysql, not a phpBB bug:

http://www.phpbb.com/community/viewtopic.php?f=46&t=1195365
http://bugs.mysql.com/bug.php?id=4541

How to repeat:
Everytime I try to install phpBB
[29 Nov 2008 17:37] Jon Stephens
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.
[29 Nov 2008 17:42] Jon Stephens
Duplicate of Bug#4541 (as mentioned by submitter).

Workaround: Don't use UTF8 or other multi-byte character set the primary key column. Note that you can specify character sets and collations on a per-column basis when creating tables. See http://dev.mysql.com/doc/refman/6.0/en/create-table.html for details.