Bug #4109 Unable to Install V4.0.20a on Windows
Submitted: 11 Jun 2004 16:53 Modified: 26 Aug 2004 6:06
Reporter: Jesse M. Heines Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:4.0.20a OS:Windows (Windows 2000)
Assigned to: MySQL Verification Team CPU Architecture:Any

[11 Jun 2004 16:53] Jesse M. Heines
I am trying to install 4.0.20a on top of 4.0.17.  I have not uninstalled 4.0.17, but I have stopped the server.  My installation directory is C:\Program Files\MySQL.  I have also tried C:\PROGRA~1\MySQL.

The installation process is giving me the following error:

[Dialog Box Title] MySQL Servers and Clients 4.0.20a

An error occurred during the move data process: -103
Component: Servers
File Group:

I click OK and the installation then exits.

I then installed this version to a new directory, C:\Program Files\MySQL-v4.0.20a.  This worked, but trying to start winmysqladmin.exe gave me an error message saying that it couldn't find DLL libeay32.dll on my path.  This DLL is on my system in a variety of places, so I copied one to the MySQL bin directory.  I then got the same error on ssleay32.dll.

Finally, I took all the defaults and installed MySQL to C:\MySQL.  I got the same errors when I tried to run winmysqladmin.exe.

Please tell me what I'm doing wrong here.

How to repeat:
Please see above.
[18 Jun 2004 3:44] MySQL Verification Team
First the Install issue:

The error for you reported happens when the installer tries to write
a file and gets an denied write OS operation due the same binary is
running. So for you be sure, try CRTL+ALT+DEL and verify if the server
or a client executable has a process running, also if you have a client
which uses the libmysql.dll should cause the same error.

Regarding WinMySQLAdmin please copy to the \mysql\bin directory the
\mysql\lib\opt\libmysql.dll file and try again.

Notice that if you install the stuff in another location than the
default c:\mysql you need to create the my.ini file in your windir
directory (e.g.: windows\winnt\custom_windir) and to edit the 
variables basedir and datadir pointing for the correct paths.

Further information you can find at:

[26 Jun 2004 5:36] Jerry NOT_FOUND
install shield crashes after the progress bar completes to 100%.  the service does not get created.  i had to create the service manually.  i starts, but i have permission issues connecting to the database.
[26 Jun 2004 17:37] MySQL Verification Team
Yes you need to create the service either manually or using
a client tool because currently the installer don't install
the service during the setup process.
What exactly the permissions problems are you having ?
[12 Jul 2004 22:42] LC A
I am using version 4.0.20d and found that the service will not start up unless the software is installed in the root folder. Installing it into c:\progra~1\mysql of c:\program files\mysql will work but the service will not start up.

   These were my reproduction steps:

   1. Download and install http://dev.mysql.com/get/Downloads/MySQL-4.0/mysql-4.0.20d-win.zip/from/ftp://mysql.mirror...

   2. Specify installation folder "c:\program files\mysql"

   3. After installation, goto Start Menu->Run and enter "cmd"

   4. On the command prompt, enter the following commands:

      a) c:
      b) cd \progra~1\mysql\bin
      c) mysqld -install

   5. Reboot computer.


   1. Service not started automatically
   2. Trying to start service manyally using Window's service control manager displays an error message


   1. The problem can be circumvented by insatlling MySQL into "c:\mysql"
[25 Aug 2004 22:18] Patrick Galbraith
Miguel asked me to assign to him.
[26 Aug 2004 6:03] MySQL Verification Team
Mysql service installed with server at Program Files directory

Attachment: service-install.JPG (image/jpeg, text), 48.99 KiB.

[26 Aug 2004 6:06] MySQL Verification Team

I installed the server in the Program Files\mysql directory without

Please using in this page the tab Files see the picture attached
how to configure the my.ini file and the install and start process.