Bug #40977 configure fails on innodb
Submitted: 24 Nov 2008 13:30 Modified: 9 Jun 2009 13:03
Reporter: Oli Sennhauser Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S2 (Serious)
Version:mysqlcom-5.1.29-ndb-6.3.19-telco OS:Any
Assigned to: Joerg Bruehe CPU Architecture:Any
Triage: Triaged: D3 (Medium) / R6 (Needs Assessment) / E6 (Needs Assessment)

[24 Nov 2008 13:30] Oli Sennhauser
Description:
Compiling the new cluster releases fails in configure phase.

How to repeat:
./configure --prefix=/home/mysql/product/mysqlcom-5.1.29-ndb-6.3.19-telco --with-plugins=max
...
config.status: creating storage/heap/Makefile
config.status: creating storage/innobase/Makefile
config.status: error: cannot find input file: storage/innobase/Makefile.in

Suggested fix:
no idea.

But workaround with --without-plugin-innobase works according to customer.
[25 Nov 2008 11:30] Geert Vanderkelen
Was still working with mysqlcom-5.1.27-ndb-6.3.17-telco, but not anymore in 6.3.19.
But this isn't "Widespread".
[27 Nov 2008 13:55] Omer Barnir
triage: setting to Cluster as specific to it and not a general compiling issue
[16 Apr 2009 13:53] Jonathan Miller
Need re verified on current source.
[17 Apr 2009 9:23] Oli Sennhauser
I took the following package to verify, hoping it is the correct replacement for the initial one: mysql-cluster-com-6.3.24.tar.gz

It looks like, now is everything working fine:

..
config.status: creating storage/example/Makefile
config.status: creating storage/federated/Makefile
config.status: creating storage/heap/Makefile
config.status: creating storage/myisam/Makefile
...
[17 Apr 2009 9:42] Joerg Bruehe
The cluster team prefers to have different source packages,
with and without InnoDB.
The one that includes InnoDB is called "com-pro", whereas "com" is without InnoDB.

This applies to all release builds done by the build team, starting with cluster versions 6.2.17, 6.4.2, and 7.0.5.
It was not yet implemented for 6.3.20.

Version 6.3.24 was not handled by the build team, so I cannot tell whether "mysql-cluster-com-6.3.24.tar.gz" does contain InnoDB or not.
[16 May 2009 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[9 Jun 2009 13:03] Joerg Bruehe
Had hoped for some feedback ...

I checked the source tarballs of cluster-6.3.24:
They comply with the policy regarding InnoDB, that means
- mysql-cluster-com-6.3.24.tar.gz      does *not* contain InnoDB,
- mysql-cluster-com-pro-6.3.24.tar.gz  *does* contain it.

Any build using a "com" package (as opposed to "com-pro")
must not try to access InnoDB, or else it will fail.

In our release builds, any "cluster-com" build uses "--without-innodb"
whereas "cluster-com-pro" and "cluster-gpl" both use "--with-innodb".

So the reported behaviour is a consequence of a source handling change which was requested by the cluster team, and is now applied to all server versions.