Bug #40726 Package Load Failure in VS2008 after installing Connector .NET v5.2.4
Submitted: 14 Nov 2008 4:01 Modified: 21 Nov 2008 14:20
Reporter: Marvin Palmer Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:5.2.4 OS:Microsoft Windows (XP Pro SP2)
Assigned to: CPU Architecture:Any
Tags: Connector .NET, Visual Studio 2008

[14 Nov 2008 4:01] Marvin Palmer
Description:
Visual Studio 2008 displays the following error three times on start-up.

"Package Load Failure

Package 'MySql.Data.VisualStudio.MySqlDataProviderPackage, MySql.VisualStudio, Version=5.2.4, Culture=neutral, PublicKeyTopen=null' has failed to load properly (GUID = {79A115C9-B133-4891-9E7B-242509DAD272}).  Please contact the package vendor for assistance.  Application restart is recommended, due to possible environment corruption.  Would you like to disable loading the package in the future?  You may use 'devenve/resetskippkgs' to re-enable package loading."

How to repeat:
Uninstalled Connector v5.2.3, downloaded Windows Binaries and used installer to install Connector v5.2.4, restarted computer, and started up Visual Studio 2008 Professional.

Suggested fix:
no ideas
[14 Nov 2008 12:06] Frank Witthaus
The same happens with Visual Studio 2005 SP1 on Windows XP.
[14 Nov 2008 16:13] Marco Cianciaruso
The same happen if try to add connection from "Server Explorer".
I Use XPpro and Vs2008
[14 Nov 2008 16:21] Reggie Burnett
I've confirmed this guys. Sorry about that. Something went wrong in packaging.  I'll get this fixed and get 5.2.5 out today.
[14 Nov 2008 18:40] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/58830
[14 Nov 2008 18:41] Reggie Burnett
fixed in 5.2.5
[14 Nov 2008 18:51] Reggie Burnett
Marvin

Can you try out the packages I just uploaded to http://kenai.com/projects/connector-net/downloads and let me know if they work for you?  

Thanks
Reggie
[17 Nov 2008 14:07] Nalle Jacobsson
Verified, now working for me in VS 2008!
[17 Nov 2008 15:02] Marvin Palmer
I tested the package.  I do not get the Package Load Failure error now when starting VS2008, and I was able to create a simple project with GridView and SqlDataSource connected to MySql database on my local machine.  Seems to work now.  Thanks, Reggie.
[19 Nov 2008 4:17] Mohammed Al-Qarni
It also works for me, BUT, Another annoying small message box appears when I press the OK button on the Add Connection dialog box. It says : "File not found".

Windows XP(Service Pack 3) + VS 2005 (SP1)
[19 Nov 2008 20:11] Carlos Medrano
error screeshot

Attachment: error.jpg (image/jpeg, text), 17.00 KiB.

[20 Nov 2008 22:12] Mohammed Al-Qarni
It also works for me, BUT, Another annoying small message box appears when I press the OK
button on the Add Connection dialog box. It says : "File not found".

Windows XP(Service Pack 3) + VS 2005 (SP1)

============================================

I just want to tell you that the above mentioned error seems to not be connected with CONNECTOR/NET 5.2.5.
Just forget about my comment above.
[21 Nov 2008 14:20] Tony Bedford
An entry has been added to the 5.2.5 changelog:

Visual Studio 2008 displayed the following error three times on start-up:

"Package Load Failure

Package 'MySql.Data.VisualStudio.MySqlDataProviderPackage, MySql.VisualStudio,
Version=5.2.4, Culture=neutral, PublicKeyTopen=null' has failed to load properly (GUID =
{79A115C9-B133-4891-9E7B-242509DAD272}).  Please contact the package vendor for
assistance.  Application restart is recommended, due to possible environment corruption. 
Would you like to disable loading the package in the future?  You may use
'devenve/resetskippkgs' to re-enable package loading."