Bug #40598 crashes in wb 5.1.4
Submitted: 9 Nov 2008 15:14 Modified: 30 Mar 2009 14:50
Reporter: Markus Gschwendt Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.1.5 OS:Linux (ubuntu 8.10, 64 bit)
Assigned to: Maksym Yehorov CPU Architecture:Any
Tags: crash, foreign key
Triage: Needs Triage: D1 (Critical)

[9 Nov 2008 15:14] Markus Gschwendt
Description:
chanching properties of FK
   setting the column of the FK to NOT NULL
   deleting FK
opening a text object (by doubleclick) for editing
editing tablename in table editor

How to repeat:
i could not reproduce the crashes everytime, but quite often. so i don't know if it depends on the db-model im working on. to me, it sees t be a problem in the frontend.

@ editing tablename in table editor.
maybe this happens only if the table is o n a layer object. even if this layer object has been deleted. or maybe if there are more than 3 tables in the model. i could not verify this crash on new db-models containing less than 3 tables.
[11 Nov 2008 14:50] Miguel Solorzano
Thank you for the bug report.
[12 Nov 2008 11:12] Maksym Yehorov
Fixed in revno# 3538
[13 Dec 2008 20:24] Markus Gschwendt
still crashes if i insert a table, edit the table name.
[13 Dec 2008 20:36] Markus Gschwendt
maybe this happens only after the third table in the diagram.
[13 Dec 2008 20:46] Markus Gschwendt
the foreign key issue is also present in wb 5.1.5.
[17 Dec 2008 16:38] qxzvd zqycp
This issue is still here in 5.1.5 Alpha (Ubuntu .deb package install).

I've got a model that I'm working on and when I try to edit the table name or change the collation of my 4th table the app crashes. There are no errors or anything, it just closes without any warning.
[17 Dec 2008 17:56] Maksym Yehorov
The problem was possible to reproduce. The issue is fixed. Please check it in the upcoming 5.1.6 release. Thanks for the reports, those helped us to reaveal and fix a bug.
[26 Jan 2009 9:24] Valeriy Kravchuk
Bug #42332 was marked as a duplicate of this one.
[30 Jan 2009 12:46] Valeriy Kravchuk
Bug #42472 was marked as a duplicate of this one.
[30 Mar 2009 14:50] Johannes Taxacher
fixed in beta release 5.1.9