Bug #40502 Overwrites multiple options in my.cnf
Submitted: 4 Nov 2008 14:40 Modified: 19 Oct 2009 13:54
Reporter: Mirko Arnold Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Administrator Severity:S3 (Non-critical)
Version:1.2.14 OS:Any
Assigned to: CPU Architecture:Any
Tags: CHECKED
Triage: Triaged: D3 (Medium) / R4 (High) / E5 (Major)

[4 Nov 2008 14:40] Mirko Arnold
Description:
See synopsis

How to repeat:
Example for Replication in my.cnf:

binlog-ignore-db=mysql
binlog-ignore-db=information_schema

The MySQL-Administrator shows only the last value: "information_schema", but after saving, the first value is overwritten:

binlog-ignore-db=information_schema
binlog-ignore-db=information_schema

The same behavior with other multiple options, e.g.: binlog-do-db, replicate-ignore-db ...
[5 Nov 2008 14:38] Susanne Ebrecht
Many thanks for writing a bug report.

This is related to bug #15245.

A solution for setting/displaying more then one database is needed here.

Because getting the information is important this is not a feature request this is a bug.
[28 Sep 2009 16:50] Susanne Ebrecht
Bug #47683 is set as duplicate of this bug here
[19 Oct 2009 13:54] Susanne Ebrecht
This is a duplicate of bug #15245