Bug #40012 Add an insteadof time to trigger definition
Submitted: 14 Oct 2008 9:13 Modified: 25 Oct 2008 17:28
Reporter: Cedric Sc Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: DDL Severity:S4 (Feature request)
Version:5.0 OS:Any
Assigned to: CPU Architecture:Any

[14 Oct 2008 9:13] Cedric Sc
Description:
When you create a view, you cannot always edit data. That's why I request "insteadof" triggers.

The trigger statement has to do the insert/update/delete correctly in the related tables.

I think it's only relevant for views' triggers

How to repeat:
Not relevant

Suggested fix:
CREATE
    [DEFINER = { user | CURRENT_USER }]
    TRIGGER trigger_name {AFTER | BEFORE | INSTEADOF} {INSERT | UPDATE | DELETE}
    ON tbl_name FOR EACH ROW trigger_stmt
[14 Oct 2008 14:00] Valeriy Kravchuk
Thank you for a reasonable feature request. INSTEAD OF triggers for views may be really useful.
[25 Oct 2008 17:28] Valeriy Kravchuk
Duplicate of Bug#16525.