Bug #39894 SHOW TABLES LIKE ... in INFORMATION_SCHEMA is case-sensitive
Submitted: 6 Oct 2008 22:24 Modified: 10 Oct 2008 21:11
Reporter: Arjen Lentz Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Information schema Severity:S3 (Non-critical)
Version:5.1.28-rc, 5.0, 5.1, 6.0 bzr OS:Any
Assigned to: Sergei Glukhov CPU Architecture:Any
Tags: information_schema, show tables
Triage: Needs Triage: D3 (Medium)

[6 Oct 2008 22:24] Arjen Lentz
Description:
SHOW TABLES LIKE ... in INFORMATION_SCHEMA is case-sensitive

How to repeat:
USE INFORMATION_SCHEMA

mysql> show tables like 'INNO%';
+--------------------------------------+
| Tables_in_information_schema (INNO%) |
+--------------------------------------+
| INNODB_CMP_RESET                     | 
| INNODB_TRX                           | 
| INNODB_CMPMEM_RESET                  | 
| INNODB_LOCK_WAITS                    | 
| INNODB_CMP                           | 
| INNODB_LOCKS                         | 
| INNODB_CMPMEM                        | 
+--------------------------------------+
7 rows in set (0.00 sec)

mysql> show tables like 'inno%';
Empty set (0.01 sec)

Suggested fix:
Make this variety of SHOW command insensitive, like all the others.
[7 Oct 2008 7:55] Sveta Smirnova
Thank you for the report.

Verified as described. Not only INFORMATION_SCHEMA affected, but any SHOW TABLES LIKE
[7 Oct 2008 7:57] Sveta Smirnova
Workaround:

select table_name from information_schema.tables where table_name like 'tabl%' and table_schema='information_schema';
[10 Oct 2008 13:21] Arjen Lentz
Gluh - if you mark a bug as a dup, PLEASE put a comment in with which bug it's a dup to?
I didn't find it earlier (which is why I filed this one) and just in general it's really important to have the cross-references.
So, please let know here which bug# you're referring to! Thanks
[10 Oct 2008 14:42] Sveta Smirnova
Arjen, this is duplicate of bug #34921
[10 Oct 2008 21:11] Arjen Lentz
Thanks Sveta - perhaps also update the other bug then with the addition version#s that are listed on this bug? And tags? Thanks
[21 Jan 2010 19:02] Paul Dubois
See http://dev.mysql.com/doc/refman/5.1/en/charset-collation-information-schema.html.