Bug #39757 Wrong RAM usage warning when more than 4GB memory is available
Submitted: 30 Sep 2008 14:35 Modified: 21 Jul 2009 9:49
Reporter: Kay Roepke Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Agent Severity:S3 (Non-critical)
Version:2.0.0.7092 OS:Mac OS X (10.5)
Assigned to: Kay Roepke CPU Architecture:Any
Tags: kay_merlin_immediate, sigar

[30 Sep 2008 14:35] Kay Roepke
Description:
When a server has more than 4GB RAM available it still triggers the memory advisor, due to an overflowing value somewhere.

How to repeat:
Run the agent on a server that has just more than 4 GB of free memory. It should trigger the advisor giving you a wrong value for the available system memory.

Suggested fix:
Unsure where the actual problem is, the sigar code looks correct, as does the agent code.
Further investigation necessary.
[30 Sep 2008 18:33] Gary Whizin
QA: please reproduce on another system with > 4 GB RAM
[30 Sep 2008 20:52] Carsten Segieth
the 2 rules that checks RAM show correct values on 'blade09', an Ubuntu 6.10 with 10G RAM:
- "RAM Usage Excessive" does not fire
- "Key Buffer Size May Not Be Optimal For System RAM" fires (OK, only 0.16 % used for the buffer ...)

Only problem at the moment is, that for the "Key buffer ..." one I do not receive any mails although the Notification log says the mails are sent. But that's a different problem ...
[1 Oct 2008 6:58] Carsten Segieth
the RAM graph for this Ubuntu system shows "free" values around ~ 6GB, which fits to the value grabbed from the success check of the "RAM Usage Excessive" rule:

Evaluated Expression
(6427361280 / 1024 / 1024) < 300

I'm not sure whether we need to 'generate' a value just few above 4G to get this problem?
[11 Nov 2008 19:38] Gary Whizin
Can anyone reproduce this? As of 2008-11-11, we cannot...
[12 Dec 2008 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[12 Dec 2008 0:04] Kay Roepke
This still shows up, but is a bit tricky to reproduce.
[20 Jan 2009 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[2 Jun 2009 12:20] Kay Roepke
waiting for build
[4 Jun 2009 19:49] Keith Russell
Patch installed in versions => 2.1.0.1056.
[21 Jul 2009 9:49] Tony Bedford
An entry was added to the 2.1.0 changelog:

On Mac OS X when a server had more than 4GB RAM available the memory advisor was still triggered. This appeared to be due to an overflowing value.