Bug #39705 read_many_rows_innodb fails
Submitted: 28 Sep 2008 4:24 Modified: 12 May 2011 10:52
Reporter: Hakan Küçükyılmaz Email Updates:
Status: Duplicate Impact on me:
None 
Category:Tests Severity:S3 (Non-critical)
Version:6.0, 6.0-falcon, 5.1 OS:Any
Assigned to: CPU Architecture:Any
Triage: Triaged: D3 (Medium)

[28 Sep 2008 4:24] Hakan Küçükyılmaz
Description:
read_many_rows_innodb fails with
  ERROR HY000: Lock wait timeout exceeded; try restarting transaction
or sometimes with
mysqltest: In included file "./include/read_many_rows.inc": At line 128: query 'insert into t2 values(123)' failed: 1062: Duplicate entry '123' for key 'PRIMARY'

How to repeat:
./mysql-test-run.pl --big-test --force --skip-ndb read_many_rows_innodb

=======================================================

TEST                           RESULT         TIME (ms)
-------------------------------------------------------

main.read_many_rows_innodb     [ fail ]

mysqltest: In included file "./include/read_many_rows.inc": At line 116: query 'reap' failed with wrong errno 1205: 'Lock wait timeout exceeded; try restarting transaction', instead of 1213...

The result from queries just before the failure was:
< snip >
DECLARE CONTINUE HANDLER FOR SQLSTATE '40001' SET @b:= 'deadlock';
DECLARE CONTINUE HANDLER FOR SQLEXCEPTION SET @a:= 'exception';
INSERT INTO t2 (f2) VALUES (1);
[28 Sep 2008 7:42] Valeriy Kravchuk
Fails for me with a timeout on 6.0-bzr:

openxs@suse:/home2/openxs/dbs/6.0/mysql-test> ./mysql-test-run.pl --big-test --force --skip-ndb read_many_rows_innodb
Logging: ./mysql-test-run.pl --big-test --force --skip-ndb read_many_rows_innodb
MySQL Version 6.0.7
Using dynamic switching of binlog format
Skipping ndbcluster
Setting mysqld to support SSL connections
Binaries are debug compiled
Using MTR_BUILD_THREAD      = 0
Using MASTER_MYPORT         = 9306
Using MASTER_MYPORT1        = 9307
Using SLAVE_MYPORT          = 9308
Using SLAVE_MYPORT1         = 9309
Using SLAVE_MYPORT2         = 9310
Killing Possible Leftover Processes
Removing Stale Files
Creating Directories
Installing Master Database
Saving snapshot of installed databases
=======================================================

TEST                           RESULT         TIME (ms)
-------------------------------------------------------

main.read_many_rows_innodb     [ fail ]  timeout
[12 May 2011 10:52] Bjørn Munch
This is a duplicate of Bug #37635.