Bug #3965 Can't build manual: make manual.html produces unmatched ( error
Submitted: 2 Jun 2004 14:24 Modified: 4 Jun 2004 1:10
Reporter: Sergey Petrunya Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Documentation Severity:S2 (Serious)
Version:mysqldoc tree in bk OS:
Assigned to: CPU Architecture:Any
Triage: D4 (Minor)

[2 Jun 2004 14:24] Sergey Petrunya
Description:
Can't build manual: make manual.html produces unmatched ( in regex error.
I was able to successfully build the manual some time ago, so the problem is likely to be in recent changes in Support/texi2html.

How to repeat:
Try building the manual and get this error: 
$ make manual.html
Support/texi2html -number manual.texi
Unmatched ( in regex; marked by <-- HERE in m/( <-- HERE ^/ at Support/texi2html line 889.
make: *** [manual.html] Error 255
[4 Jun 2004 0:32] Sergey Petrunya
The problem goes away if one undoes the following changeset: 
Changeset 1.1726 2004/06/01 11:10:02 jimw@mysql.com
[4 Jun 2004 1:10] Jim Winstead
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html