Bug #39587 Missing table INFORMATION_SCHEMA.ROUTINE_PRIVILEGES
Submitted: 22 Sep 2008 13:16 Modified: 22 Sep 2008 13:50
Reporter: Kristian Köhntopp Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Information schema Severity:S2 (Serious)
Version:5.1.2 OS:Any
Assigned to: CPU Architecture:Any

[22 Sep 2008 13:16] Kristian Köhntopp
Description:
In 5.0, the table information_schema.routine_privileges had been left out and supposedly could not be added due to release management reasons. It should have been mapping to mysql.procs_priv.

Checking back with 5.1.26, that table is still missing.

How to repeat:
kris@localhost [information_schema]> show tables like "%priv%";
+---------------------------------------+
| Tables_in_information_schema (%priv%) |
+---------------------------------------+
| COLUMN_PRIVILEGES                     | 
| SCHEMA_PRIVILEGES                     | 
| TABLE_PRIVILEGES                      | 
| USER_PRIVILEGES                       | 
+---------------------------------------+
4 rows in set (0.00 sec)

kris@localhost [information_schema]> select version();
+-----------+
| version() |
+-----------+
| 5.1.26-rc | 
+-----------+
1 row in set (0.00 sec)

Suggested fix:
Add routine_privileges, and map it to mysql.procs_priv.
[22 Sep 2008 13:50] Miguel Solorzano
Thank you for the bug report. Duplicate of bug: http://bugs.mysql.com/bug.php?id=26886.