Bug #39435 InnoDB plugin auto_inc test fails
Submitted: 14 Sep 2008 3:37 Modified: 15 Sep 2008 22:47
Reporter: Vadim TKACHENKO Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB Plugin storage engine Severity:S2 (Serious)
Version:5.1.28 + 1.0.1 plugin OS:Any
Assigned to: Sunny Bains CPU Architecture:Any

[14 Sep 2008 3:37] Vadim TKACHENKO
Description:
5.1.28 with compiled in InnoDB plugin 1.0.1 fails on  innodb.auto_inc test.

On query
mysql> INSERT INTO t1 VALUES (NULL), (NULL), (NULL);

We got
ERROR 1062 (23000): Duplicate entry '1' for key 'PRIMARY'

But I expect for auto_inc column value will be autoincremented

How to repeat:
mysql> CREATE TABLE `t1` (
    ->   `c1` int(11) NOT NULL AUTO_INCREMENT,
    ->   PRIMARY KEY (`c1`)
    -> ) ENGINE=InnoDB AUTO_INCREMENT=7 DEFAULT CHARSET=latin1;
Query OK, 0 rows affected (0.03 sec)

mysql> INSERT INTO t1 VALUES (1), (2), (3);
Query OK, 3 rows affected (0.00 sec)
Records: 3  Duplicates: 0  Warnings: 0

mysql> INSERT INTO t1 VALUES (NULL), (NULL), (NULL);
Query OK, 3 rows affected (0.00 sec)
Records: 3  Duplicates: 0  Warnings: 0

mysql> TRUNCATE TABLE t1;
Query OK, 0 rows affected (0.01 sec)

mysql> INSERT INTO t1 VALUES (1), (2), (3);
Query OK, 3 rows affected (0.00 sec)
Records: 3  Duplicates: 0  Warnings: 0

mysql> INSERT INTO t1 VALUES (NULL), (NULL), (NULL);
ERROR 1062 (23000): Duplicate entry '1' for key 'PRIMARY'
[15 Sep 2008 7:04] Sveta Smirnova
Thank you for the report.

Verified as described. Bug is only repeatable with InnoDB Plugin.
[15 Sep 2008 22:47] Sunny Bains
This is a duplicate of Bug#37531