Bug #39385 ndb_binlog_discover fails sporadically in pushbuild (warnings in server log)
Submitted: 11 Sep 2008 9:11 Modified: 17 May 8:38
Reporter: Sven Sandberg Email Updates:
Status: Won't fix Impact on me:
None 
Category:Tests: Cluster Severity:S7 (Test Cases)
Version:5.1-rpl OS:Any
Assigned to: CPU Architecture:Any
Tags: ndb_binlog_discover, possible memleak, pushbuild, sporadic, test failure, warnings

[11 Sep 2008 9:11] Sven Sandberg
Description:
from pushbuild:

ndb.ndb_binlog_discover                  [ fail ]  Found warnings in server log file!
@log_error
/dev/shm/var-n_mix-110/2/mysql_cluster.1/mysqld.2/mysqld.err
log_error
080825 14:55:08 [Warning] NDB_SHARE: ./mysql/ndb_schema already exists  use_count=1. Moving away for safety, but possible memleak.
^ Found warnings!!

 - saving '/dev/shm/var-n_mix-110/2/log/ndb.ndb_binlog_discover/' to '/dev/shm/var-n_mix-110/log/ndb.ndb_binlog_discover/'

Retrying test, attempt(2/3)...

How to repeat:
https://intranet.mysql.com/secure/pushbuild/showpush.pl?dir=bzr_mysql-5.1-rpl&order=43 
sapsrv1/n_mix

xref: http://tinyurl.com/5qlgef
[16 Sep 2008 9:03] Andrei Elkin
Leaving out for Tomas who claims it's not a real problem. The cluster team has been watching over similar failures.
[19 Nov 2010 14:17] Joerg Bruehe
Same symptom in the release build of cluster-7.1.9a:

=====
db_team.ndb_restart                     [ retry-fail ]  Found warnings/errors in server log file!
        Test ended at YYYY-MM-DD HH:MM:SS
line
YYMMDD HH:MM:SS [Warning] NDB_SHARE: ./mysql/ndb_schema already exists use_count=1. Moving away for safety, but possible memleak.
^ Found warnings in /PATH/mysql-test/var/log/mysqld.2.1.err
ok

 - saving '/PATH/mysql-test/var/log/ndb_team.ndb_restart/' to '/PATH/mysql-test/var/log/ndb_team.ndb_restart/'
=====

Happened on Solaris 10, x86_64.
[12 Oct 2011 8:24] Steven Ayre
also reproducable on cluster-7.1.15a (debian squeeze amd64)
[12 Oct 2011 8:25] Steven Ayre
(previous comment refers to ndb_team.ndb_restart test case as reported by Joerg Bruehe)
[17 May 8:38] Magnus Blåudd
Posted by developer:
 
This test failure does not occur anymore, the ndb_binlog_discover test is known to be stable.

The warning messages doesnät even exist since 8 as the NDB_SHARE functionality was revised as part of new data dictionary (DD).

Closing as rejected.