Bug #39360 EER diagram corrupted, not usable anymore
Submitted: 10 Sep 2008 7:31 Modified: 17 Dec 2008 16:10
Reporter: - - Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.0.24, 5.0.26, 5.0.27 OS:Any
Assigned to: Alfredo Kojima CPU Architecture:Any
Triage: D1 (Critical)

[10 Sep 2008 7:31] - -
Description:
My unique EER diagram throws exception whatever the action I perform. It is not usable anymore :

Consultez la fin de ce message pour plus de détails sur l'appel du débogage
juste-à-temps (JIT) à la place de cette boîte de dialogue.

************** Texte de l'exception **************
System.Runtime.InteropServices.SEHException: Un composant externe a levé une exception.
   à wb.ModelViewForm.handle_mouse_button(ModelViewForm* , MouseButton , Boolean , Int32 , Int32 , EventState )
   à MySQL.Workbench.ModelViewForm.OnMouseUp(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   à MySQL.GUI.Workbench.ModelViewForm.CanvasPanel_MouseUp(Object sender, MouseEventArgs e)
   à System.Windows.Forms.Control.OnMouseUp(MouseEventArgs e)
   à MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseUp(MouseEventArgs e)
   à System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   à System.Windows.Forms.Control.WndProc(Message& m)
   à System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   à System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Assemblys chargés **************
mscorlib
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase : file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
MySQLWorkbench
    Version de l'assembly : 5.0.24.3407
    Version Win32 : 5.0.24.3407
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/MySQLWorkbench.exe
----------------------------------------
wb.wr
    Version de l'assembly : 0.0.0.0
    Version Win32 : 
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/wb.wr.DLL
----------------------------------------
grt.wr
    Version de l'assembly : 0.0.0.0
    Version Win32 : 
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/grt.wr.DLL
----------------------------------------
System.Windows.Forms
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase : file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase : file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase : file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
MySQLCsUtilities
    Version de l'assembly : 1.0.0.0
    Version Win32 : 1.0.0.0
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/MySQLCsUtilities.DLL
----------------------------------------
msvcm80
    Version de l'assembly : 8.0.50727.1433
    Version Win32 : 8.00.50727.1433
    CodeBase : file:///C:/WINDOWS/WinSxS/x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.1433_x-ww_5cf844d2/msvcm80.dll
----------------------------------------
MySQLGrtShell
    Version de l'assembly : 1.0.0.0
    Version Win32 : 1.0.0.0
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/MySQLGrtShell.EXE
----------------------------------------
WeifenLuo.WinFormsUI.Docking
    Version de l'assembly : 2.2.3145.31939
    Version Win32 : 2.2.0.0
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/WeifenLuo.WinFormsUI.Docking.DLL
----------------------------------------
MySQLWorkbenchEditors
    Version de l'assembly : 1.0.0.0
    Version Win32 : 1.0.0.0
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/MySQLWorkbenchEditors.DLL
----------------------------------------
System.Configuration
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase : file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase : file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Accessibility
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase : file:///C:/WINDOWS/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
Aga.Controls
    Version de l'assembly : 1.6.0.0
    Version Win32 : 1.6.0.0
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/Aga.Controls.DLL
----------------------------------------
System.Windows.Forms.resources
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase : file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms.resources/2.0.0.0_fr_b77a5c561934e089/System.Windows.Forms.resources.dll
----------------------------------------
grt.helpers.be
    Version de l'assembly : 1.0.0.0
    Version Win32 : 1.0.0.0
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/grt.helpers.be.DLL
----------------------------------------
mscorlib.resources
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.1433 (REDBITS.050727-1400)
    CodeBase : file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------

************** Débogage JIT **************
Pour activer le débogage juste-à-temps (JIT), le fichier de configuration pour cette
application ou cet ordinateur (machine.config) doit avoir la valeur
jitDebugging définie dans la section system.windows.forms.
L'application doit également être compilée avec le débogage
activé.

Par exemple :

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

Lorsque le débogage juste-à-temps est activé, les exceptions non gérées
seront envoyées au débogueur JIT inscrit sur l'ordinateur
plutôt que d'être gérées par cette boîte de dialogue.

How to repeat:
Last action I made was moving a table on ma EER diagram. After that, I was reported an exception and I have to close workbench. Now table has disappeared from diagram and the same exception is thrown whatever the action I do on diagram.
[10 Sep 2008 8:21] Valeriy Kravchuk
Thank you for a problem report. Please, upload problematic .mwb file.
[10 Sep 2008 8:33] - -
I'm sorry, I can't upload mwb file, our database schema is confidential.
[10 Sep 2008 8:43] Valeriy Kravchuk
Then I need a repeatable sequence of actions (not related to your confidential schema) to reproduce the problem. This will speed up bug fixing a lot.
[10 Sep 2008 8:54] - -
Well I can't say much more : I have selected a dozen of relationships to hide them, then I have selected a table, then I tried to move this table using drag&drop before having this exception.

Since I had same exception each time I perform an action on this diagram (e.g. move or edit a table), I closed Workbench. But it was the same issue when I reopen it.

Now I can't use this diagram anymore. I am able to create another one in same mwb file, but I'd prefer to avoid re-arranging my 60 tables, and I'm now afraid to go on with this release...
[12 Sep 2008 11:34] Valeriy Kravchuk
Please, try to repeat with a newer version, 5.0.25, and inform about the results.
[12 Sep 2008 19:36] - -
Same result
[15 Sep 2008 16:37] Miguel Solorzano
This happens on your side with any project file or just with that confidential one? otherwise could you provide one without confidential data?. Thanks in advance.
[16 Sep 2008 8:17] - -
This happens only with my main EER diagram. As I said before, other EER diagrams belonging to the same mwb file work. Even if I export SQL from corrupted diagram and import it in another diagram, it works.
[14 Oct 2008 15:26] Valeriy Kravchuk
Please, try to repeat with a newer version, 5.0.26, and inform about the results.
[15 Oct 2008 6:48] - -
Still the same exception with 5.0.26.
[15 Oct 2008 9:33] - -
Couldn't you provide more details when you report this kind of exceptions (i.e. the root cause) ?
[18 Nov 2008 12:16] Susanne Ebrecht
Many thanks for all your feedback.

For making a deeper analysis here we need the file from you. You can upload it by using:
http://bugs.mysql.com/bug.php?id=39360&files=1

Please set the privacy field to: Only developers will be able to see the file

This will occur that only the Sun MySQL employees with developer rights for MySQL bugs will see the files.

Your problem sounds like a corrupted file. But Workbench should not produce corrupted files and when a corrupted file exist Workbench should not thrown off course in such a way.

But for checking what goes wrong here we need the file.

You also could give it a try and try the newest version 5.0.27.
[18 Nov 2008 12:44] - -
No change with 5.0.27.

I've ended up to upload corrupted file. Please, remember it's confidential.

Just move a table on 'all' model.
[23 Nov 2008 21:18] Valeriy Kravchuk
Verified just as described with your file.
[4 Dec 2008 21:34] Johannes Taxacher
this has been fixed. fix will be in 5.0.28
[9 Dec 2008 10:24] Tony Bedford
An entry was added to the 5.0.28 changelog:

A complex EER diagram threw an exception whenever an action was peformed on it. However, other diagrams in the same MWB file functioned correctly.

The exception generated was:

System.Runtime.InteropServices.SEHException: Un composant externe a levé une exception.
   à wb.ModelViewForm.handle_mouse_button(ModelViewForm* , MouseButton , Boolean , Int32
, Int32 , EventState )
   à MySQL.Workbench.ModelViewForm.OnMouseUp(MouseEventArgs e, Int32 X, Int32 Y, Keys
keystate, MouseButtons buttons)
   à MySQL.GUI.Workbench.ModelViewForm.CanvasPanel_MouseUp(Object sender, MouseEventArgs
e)
   à System.Windows.Forms.Control.OnMouseUp(MouseEventArgs e)
   à MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseUp(MouseEventArgs e)
   à System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32
clicks)
   à System.Windows.Forms.Control.WndProc(Message& m)
   à System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   à System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam,
IntPtr lparam)
[17 Dec 2008 16:10] - -
Now this bug is resolved I've been working again on it for several hours, this product really begins to rock :-)