Bug #38889 Assignment of a variable to "slow_query_log_file" failed.
Submitted: 19 Aug 2008 11:14 Modified: 4 Dec 2008 11:07
Reporter: Horst Hunger Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Logging Severity:S3 (Non-critical)
Version:6.0.7-alpha-debug OS:Linux (suse-linux-gnu on i686)
Assigned to: Georgi Kodinov CPU Architecture:Any
Triage: Triaged: D4 (Minor)

[19 Aug 2008 11:14] Horst Hunger
Description:
After execution of 
SET @my_var= "mytestvar.log";
SET @@global.slow_query_log_file= @my_var;
SELECT @@global.slow_query_log_file;

the result of the last select is  "/work/bzr/mysql-6.0-rpl/mysql-test/var/run/mysqld-slow.log" and not
"mytestvar.log".

How to repeat:
execute the attached test.

Suggested fix:
Either reject the assignment with a bug and describe the restriction in the manual or do the assignment as expected.
[19 Aug 2008 12:44] Miguel Solorzano
Thank you for the bug report.
[19 Aug 2008 15:55] Valeriy Kravchuk
Other variables can be set this way:

C:\Program Files\MySQL\MySQL Server 5.1\bin>mysql -uroot -P3311 test
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 1
Server version: 6.0.5-alpha-community MySQL Community Server (GPL)

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> set @var=300000;
Query OK, 0 rows affected (0.00 sec)

mysql> set @@global.sort_buffer_size=@var;
Query OK, 0 rows affected (0.03 sec)

mysql> show global variables like 'sort%';
+------------------+--------+
| Variable_name    | Value  |
+------------------+--------+
| sort_buffer_size | 300000 |
+------------------+--------+
1 row in set (0.20 sec)
[27 Oct 2008 22:07] Konstantin Osipov
Duplicate of Bug#38124