Bug #38847 Operating system error number 33
Submitted: 18 Aug 2008 11:00 Modified: 15 Jul 2012 15:45
Reporter: Pierre-Olivier BEDNARZ Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Errors Severity:S1 (Critical)
Version:5.0.30 OS:Microsoft Windows (server 2003)
Assigned to: CPU Architecture:Any
Tags: Operating system error number 33 in a file operation.

[18 Aug 2008 11:00] Pierre-Olivier BEDNARZ
Description:
Some times, the MySQL database stop connections.
When we re start the application, we have a connection denied (2003)
We must re start the serveur to connect on MySQL database.

Copy of "server.err":

080818  0:40:00  InnoDB: Started; log sequence number 2 3237153637
080818  0:40:01 [Note] E:\MySQL\MySQL Server 5.0\bin\mysqld-nt: ready for connections.
Version: '5.0.30-enterprise-gpl-nt'  socket: ''  port: 3306  MySQL Enterprise Server (GPL)
080818 10:30:07  InnoDB: Operating system error number 33 in a file operation.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.0/en/operating-system-error-codes.html
InnoDB: File name E:\MySQL\\MySQL Datafiles\ibdata1
InnoDB: File operation call: 'aio write'.
InnoDB: Cannot continue operation.
080818 11:10:59  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
080818 11:11:03  InnoDB: Starting log scan based on checkpoint at
InnoDB: log sequence number 2 3237768296.
InnoDB: Doing recovery: scanned up to log sequence number 2 3237790961
080818 11:11:04  InnoDB: Starting an apply batch of log records to the database...
InnoDB: Progress in percents: 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 
InnoDB: Apply batch completed
080818 11:11:05  InnoDB: Started; log sequence number 2 3237790961
080818 11:11:06 [Note] E:\MySQL\MySQL Server 5.0\bin\mysqld-nt: ready for connections.
Version: '5.0.30-enterprise-gpl-nt'  socket: ''  port: 3306  MySQL Enterprise Server (GPL)

How to repeat:
I don't no how to repeat this bug.
[18 Aug 2008 12:29] Miguel Solorzano
Thank you for the bug report. The server version you have reported is quite older,
could you please upgrade to latest released version 5.0.67 and try again?. Thanks in advance.
[19 Aug 2008 9:55] Pierre-Olivier BEDNARZ
hi,

We can't make an upgrade of the data base.
The service shutdown himself somtimes.
Always error 33 in MySQL and error 7034 in windows system logs.
[19 Aug 2008 11:01] Susanne Ebrecht
Error 33 means:
The process cannot access the file because another process has locked a portion of the file. 

MySQL wasn't able to write to E:\MySQL\\MySQL Datafiles\ibdata1 because somebody else uses this file. Or because of you have had a too huge system load your operation system didn't unlock the file fast enough.

Please control your operation system load and what else happens on your operation system.

Please, also let us know if this will be ok by using MySQL 5.0.67.

Consider, even if this would be a bug and we would fix it you would have to upgrade to the newest version. So you just spend time to do an upgrade now.
[19 Sep 2008 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[5 Apr 2012 19:27] Shane Bester
Firstly, be 100% nobody except mysqld access datafiles.  Use sysinternals procmon to verify this.

Then make sure the innodb files aren't too large and/or compressed, and highly fragmented.  Try defrag the disk or just those files using "contig" from sysinternals.
[13 Jul 2012 19:05] Suhaas Zende
In my case there was an antivirus backup running having option to backup binary files as well.
During which it would wipe out binary files resulting into mysql services not coming up due to absence of binary files for recovery.

Obviously I had to uncheck the binary files backup option that resolve my issue.