Bug #38832 falcon test suite hangs predictably
Submitted: 16 Aug 2008 7:09 Modified: 19 Aug 2008 9:56
Reporter: Daniel Fischer Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Falcon storage engine Severity:S3 (Non-critical)
Version:6.0 OS:Microsoft Windows (WS2008)
Assigned to: CPU Architecture:Any

[16 Aug 2008 7:09] Daniel Fischer
Description:
With MySQL 6.0 bzr built with Visual Studio 9 2008 on Windows Vista, the falcon test suite hangs on Windows 2008 after the sixth test case:

falcon.falcon_bug_22089 [ pass ] 78 
falcon.falcon_bug_22125 [ pass ] 547 
falcon.falcon_bug_22143 [ pass ] 219 
falcon.falcon_bug_22144 [ pass ] 62
falcon.falcon_bug_22150-big [ skipped ] Test needs 'big-test' option
falcon.falcon_bug_22150 [ pass ] 185000 
<hangs indefinitely>

That the whole test suite hangs instead of timing out is reported elsewhere. 

This can either be caused by a hanging mysqld from the previous successful test case which couldn't be terminated, or by one from the test case that is executed after the last displayed test case that hangs.

How to repeat:
Build MySQL 6.0 with VS 9 2008 and run the test suite with ActivePerl.
[16 Aug 2008 8:21] Daniel Fischer
On second though, this may have been fixed in 6.0-wtf already. I'll verify and re-open if not.
[19 Aug 2008 9:56] Daniel Fischer
Closing as I've verified that this is indeed fixed in the 6.0-wtf and 6.0-falcon-team trees.