Bug #38758 utf8_german2_ci
Submitted: 12 Aug 2008 20:54 Modified: 8 Nov 2010 7:35
Reporter: Susanne Ebrecht Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Charsets Severity:S4 (Feature request)
Version:5.0, 5.1, 5.5 OS:Any
Assigned to: Alexander Barkov
Triage: Triaged: D5 (Feature request)

[12 Aug 2008 20:54] Susanne Ebrecht
Description:
I got a ping because of http://forums.mysql.com/read.php?70,222189,222189

The question is in German.

It is again a feature request for utf8_german2_ci

Germans are more familiar with german2_ci then with german1_ci and I get questions for this every week.

How to repeat:
...

Suggested fix:
add utf8_german2_ci
[6 Oct 2008 11:41] Susanne Ebrecht
Bug #39816 was set as duplicate of this bug here.
[21 Jul 2010 12:18] Alexander Barkov
German2 collations have been implemented in 5.5 under terms of:

WL#4013: Unicode german2 collation
http://forge.mysql.com/worklog/task.php?id=4013
[4 Nov 2010 8:09] Susanne Ebrecht
Bug #57860 is set as duplicate of this bug here
[5 Nov 2010 14:03] Timo A. Hummel
Hi,

I'm wondering why this isn't added to 5.5. As Susanne told me in Bug 57860 this should be in 5.5, but this bug says "Version 6.0" in the Version field, but the text from Alexander says "added to 5.5". Also Version 5.5.6_rc doesn't include utf8_german2.

Can you enlighten me what the current status is?

Thanks,
Timo
[8 Nov 2010 7:35] Alexander Barkov
I am sorry for a mistake. utf8_german2_ci was added into mysql-5.6,
not into 5.5.
[8 Nov 2010 11:01] Timo A. Hummel
Is there any roadmap or preview downloads for the 5.6 release? The download folder is empty on my favourite FTP mirror, and the dev downloads here on mysql.com show only V5.5, not 5.6.