Bug #38074 rpl_row_mysqlbinlog at line 235: could not sync with master
Submitted: 12 Jul 2008 18:36 Modified: 24 Aug 2009 9:19
Reporter: Andrei Elkin Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Row Based Replication ( RBR ) Severity:S3 (Non-critical)
Version:6.0,5.4,5.0 OS:Any
Assigned to: Alfranio Correia CPU Architecture:Any
Tags: test_failure rpl_row
Triage: Triaged: D3 (Medium)

[12 Jul 2008 18:36] Andrei Elkin
Description:
        tfl_name: rpl.rpl_row_mysqlbinlog 'row'
    tfl_tst_type: rpl_binlog_row
        psh_tree: bzr_mysql-6.0-bugteam
       psh_order: 40
tfl_bld_platform: vm-win2003-32-a
        tfl_text: rpl.rpl_row_mysqlbinlog 'row'  [ fail ]

=== SHOW MASTER STATUS ===
---- 1. ----
File	slave-bin.000001
Position	3471067
Binlog_Do_DB	
Binlog_Ignore_DB	
==========================

=== SHOW SLAVE STATUS ===
---- 1. ----
Slave_IO_State	Waiting for master to send event
Master_Host	127.0.0.1
Master_User	root
Master_Port	11010
Connect_Retry	1
Master_Log_File	master-bin.000002
Read_Master_Log_Pos	692322
Relay_Log_File	slave-relay-bin.000005
Relay_Log_Pos	254
Relay_Master_Log_File	master-bin.000002
Slave_IO_Running	Yes
Slave_SQL_Running	No
Replicate_Do_DB	
Replicate_Ignore_DB	
Replicate_Do_Table	
Replicate_Ignore_Table	
Replicate_Wild_Do_Table	
Replicate_Wild_Ignore_Table	
Last_Errno	1146
Last_Error	Error 'Table 'test.t2' doesn't exist' on opening tables
Skip_Counter	0
Exec_Master_Log_Pos	107
Relay_Log_Space	692669
Until_Condition	None
Until_Log_File	
Until_Log_Pos	0
Master_SSL_Allowed	No
Master_SSL_CA_File	
Master_SSL_CA_Path	
Master_SSL_Cert	
Master_SSL_Cipher	
Master_SSL_Key	
Seconds_Behind_Master	
Master_SSL_Verify_Server_Cert	No
Last_IO_Errno	0
Last_IO_Error	
Last_SQL_Errno	1146
Last_SQL_Error	Error 'Table 'test.t2' doesn't exist' on opening tables
=========================

mysqltest: At line 235: could not sync with master ('select master_pos_wait('master-bin.000002', 692322)' returned NULL)

The result from queries just before the failure was:
< snip >
word
Aarhus
Aarhus
Aarhus
Aarhus
Aarhus
SELECT * FROM t2 ORDER BY id LIMIT 5;
id
1
2
3
4
5
SELECT c1, c3, c4, c5  FROM t3 ORDER BY c1 LIMIT 5;
c1	c3	c4	c5
1	2006-02-22 00:00:00	Tested in Texas	2.2
2	2006-02-22 00:00:00	Tested in Texas	4.4
3	2006-02-22 00:00:00	Tested in Texas	6.6
4	2006-02-22 00:00:00	Tested in Texas	8.8
5	2006-02-22 00:00:00	Tested in Texas	11

More results from queries before failure can be found in e:\var-rpl_binlog_row-101\log\rpl_row_mysqlbinlog.log

Stopping All Servers
Restoring snapshot of databases
*************************** 223. row ***************************
        tfl_name: rpl.rpl_slave_status 'stmt'
    tfl_tst_type: ps_stm_threadpool
        psh_tree: bzr_mysql-6.0-bugteam
       psh_order: 43
tfl_bld_platform: sles10-ia64-a-2
        tfl_text: rpl.rpl_slave_status 'stmt'    [ fail ]

--- /data0/pushbuild/pb2-3/pb/bzr_mysql-6.0-bugteam/43/mysql-6.0.6-alpha-pb43/mysql-test/suite/rpl/r/rpl_slave_status.result	2008-07-07 12:09:05.000000000 +0300
+++ /data0/pushbuild/pb2-3/pb/bzr_mysql-6.0-bugteam/43/mysql-6.0.6-alpha-pb43/mysql-test/suite/rpl/r/rpl_slave_status.reject	2008-07-07 14:31:37.000000000 +0300
@@ -12,25 +12,43 @@
 stop slave;
 change master to master_user='rpl',master_password='rpl';
 start slave;
-==== Do replication as new user ====
-[on master]
-create table t1 (n int);
-insert into t1 values (1);
-[on slave]
-select * from t1;
-n
-1
-==== Delete new replication user ====
-[on master]
-drop user rpl@127.0.0.1;
-flush privileges;
-[on slave]
-==== Restart slave without privileges =====
-stop slave;
-start slave;
-==== Verify that Slave_IO_Running = No ====
-Slave_IO_Running = No (should be No)
-==== Cleanup (Note that slave IO thread is not running) ====
-drop table t1;
-[on master]
-drop table t1;
+"Failed while waiting for slave to start"
+SHOW SLAVE STATUS;
+Slave_IO_State	#
+Master_Host	127.0.0.1
+Master_User	rpl
+Master_Port	MASTER_PORT
+Connect_Retry	1
+Master_Log_File	master-bin.000001
+Read_Master_Log_Pos	316
+Relay_Log_File	#
+Relay_Log_Pos	#
+Relay_Master_Log_File	master-bin.000001
+Slave_IO_Running	No
+Slave_SQL_Running	Yes
+Replicate_Do_DB	
+Replicate_Ignore_DB	
+Replicate_Do_Table	
+Replicate_Ignore_Table	
+Replicate_Wild_Do_Table	
+Replicate_Wild_Ignore_Table	
+Last_Errno	0
+Last_Error	
+Skip_Counter	0
+Exec_Master_Log_Pos	316
+Relay_Log_Space	#
+Until_Condition	None
+Until_Log_File	
+Until_Log_Pos	0
+Master_SSL_Allowed	No
+Master_SSL_CA_File	
+Master_SSL_CA_Path	
+Master_SSL_Cert	
+Master_SSL_Cipher	
+Master_SSL_Key	
+Seconds_Behind_Master	#
+Master_SSL_Verify_Server_Cert	No
+Last_IO_Errno	2013
+Last_IO_Error	error reconnecting to master 'rpl@127.0.0.1:MASTER_PORT' - retry-time: 1  retries: 10
+Last_SQL_Errno	0
+Last_SQL_Error	

mysqltest: In included file "./include/wait_for_slave_to_start.inc": Result content mismatch

Warnings from just before the error:
Note 1051 Unknown table 't1' 
Note 1051 Unknown table 't2' 
Note 1051 Unknown table 't3' 
Note 1051 Unknown table 't4' 
Note 1051 Unknown table 't5' 
Note 1051 Unknown table 't6' 
Note 1051 Unknown table 't7' 
Note 1051 Unknown table 't8'

How to repeat:
https://intranet.mysql.com/secure/pushbuild/xref.pl?startdate=&enddate=&dir=&plat=vm-win20...
      https://intranet.mysql.com/secure/pushbuild/showpush.pl?dir=bzr_mysql-6.0-bugteam&order=40
[12 Jul 2008 18:38] Andrei Elkin
Please disregard lines after
************************** 223. row ***************************
[24 Aug 2009 9:18] Alfranio Correia
This is a duplicate of BUG#46013.

revno: 1810.3925.14
revision-id: davi.arnaut@sun.com-20090813200720-utqy73cj0orcy80z