Bug #38051 Weird cluster behavior with auto_inc, trigger and INSERT INTO ... SELECT
Submitted: 11 Jul 2008 15:56 Modified: 28 Aug 2009 12:39
Reporter: Hartmut Holzgraefe Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S2 (Serious)
Version:mysql-5.1-telco-6.3 OS:Linux
Assigned to: Assigned Account CPU Architecture:Any
Tags: mysql-5.1.23-telco-6.3.14

[11 Jul 2008 15:56] Hartmut Holzgraefe
Description:
When trying to populate a cluster table with data using

  INSERT INTO table SELECT ... FROM TABLE

sometimes less then the expected number of rows are inserted if

- the table has an auto_increment primary key

- there is an INSERT trigger on the table

- INSERT INTO ... SELECT statements are done in a transaction
  without commits after each statement 

How to repeat:
See attached test case
[11 Jul 2008 15:59] Hartmut Holzgraefe
mysqltest test case

Attachment: bug38051.tgz (application/x-gtar, text), 1.05 KiB.

[11 Jul 2008 16:10] Hartmut Holzgraefe
Found while trying to verify bug #38034, might be related ...
[18 Dec 2008 10:29] Jonas Oreland
martin to estimate E/R
[28 Aug 2009 12:39] Martin Skold
Duplicate of bug#38034