Bug #3787 Support for BAG datatype
Submitted: 16 May 2004 21:23 Modified: 5 Dec 2005 12:10
Reporter: f l Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server Severity:S4 (Feature request)
Version: OS:
Assigned to: CPU Architecture:Any
Triage: D5 (Feature request)

[16 May 2004 21:23] f l
Description:
Any plans for a BAG datatype, i.e. a datatype that may contain each value several times?

How to repeat:
not a bug
[5 Dec 2005 12:10] Valeriy Kravchuk
Thank you for a feature request. Sorry, but relational data model is based on assumption that each value is atomic, has no sub-fileds or "arrays" of values. So, I do not think that BAG (or any other "collection" or "object" type) will be implemented in MySQL.