Bug #37729 'Could not fetch stored procedures' error message when try to open schema
Submitted: 29 Jun 2008 20:38 Modified: 9 Dec 2010 5:09
Reporter: Arsen Barbakadze Email Updates:
Status: Unsupported Impact on me:
None 
Category:MySQL Query Browser Severity:S1 (Critical)
Version:1.2.12 OS:Microsoft Windows (Windows XP)
Assigned to: CPU Architecture:Any

[29 Jun 2008 20:38] Arsen Barbakadze
Description:
When first time click on dropdown symbol of schema in order to see tables content then appears 'fetching data under schema name and then error message 'Could not fetch stored procedures'. Click on 'Ok' button and appears content of the schema. But when try run any script then every address to schema calls this error message again and the script is stopped.

How to repeat:
1.Launch browser
2.Click on dropdown triangle symbol next to the name of the schema comprising stored procedures.
3.Under schema name appears 'fetching data'
3. Observe that then appears error message 'Could not fetch stored procedures'
4.Click 'Ok' button, error message disappears and content of schema is showed
5.Run script which contains a reference to this schema like "use 'schema_name"
6. Script is stopped and again appears the same error message 'Could not fetch stored procedures'
[30 Jun 2008 8:29] Valeriy Kravchuk
Thank you for a problem report. What exact version of MySQL server are you connecting to?
[30 Jun 2008 16:30] Arsen Barbakadze
The server version is 5.0.45.
Thank you.
[6 Jul 2008 23:10] Arsen Barbakadze
Hey, Valeriy! Where are you? Tell me how I can handle this problem.
I cannot run my scripts. May be it's possible to switch off those procedures because I don't use them in my scripts? Or may be I have to be granted by any priveleges to see those procedures? When I run my scripts on version 4.1.12 there are no problem because it doesn't support stored procedures. Any idea?
[19 Jul 2008 14:22] Valeriy Kravchuk
Is it newly installed 5.0.45 or you had upgraded from some older version of MySQL?  

Please, send the results of:

use mysql;
show tables;

from it. Can you control that server completely or run mysql_upgrade utility on it?
[19 Aug 2008 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[11 Dec 2008 21:34] Gary Malcolm
We experienced the exact problem and it turned out the issue was a bad naming of a stored procedure with a tick (`). 

Example procedure defintion:

DROP PROCEDURE IF EXISTS mydb.test $$
CREATE PROCEDURE mydb.t`est () 

Solution:

Edit the procedure name in the mysql.proc table to omit the tick.

Hope this helps,

Gary
[6 Dec 2010 8:10] John Michael Dumaua
the bug is: Could not fetch stored procedures

what is the solution for that?
[6 Dec 2010 8:39] John Michael Dumaua
hi there! 

is there anyone who can help me from my problem in mysql?

the problem is:  I lost my "Stored Procedures" in schema and when everytime i will open the schema,there is a dialog box containing "Could not fetch stored procedures"

How can I fixed this problem?How can I restore all those Stored Procedures? 

thanks!

hoping for your help..
[6 Dec 2010 9:21] Valeriy Kravchuk
John,

Do you still use MySQL Query Browser? Had you tried to use MySQL Workbench 5.2.30 instead?
[6 Dec 2010 23:24] John Michael Dumaua
Yes, I'm still using mysql querry browser.

Can you help me regarding my problem in MySql?

Good Day! thanks
[9 Dec 2010 5:09] Valeriy Kravchuk
Sorry, but old GUI tools are unsupported for almost a year already. It means that no bugs will be fixed in them.