Bug #37715 rpl.rpl_dual_pos_advance 'mix' failed on pushbuild
Submitted: 28 Jun 2008 10:59 Modified: 11 Aug 2008 18:15
Reporter: Sven Sandberg Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Replication Severity:S7 (Test Cases)
Version:6.0 OS:Any
Assigned to: Serge Kozlov CPU Architecture:Any
Tags: pushbuild, rpl_dual_pos_advance, server log, sporadic, test failure, warning
Triage: D3 (Medium)

[28 Jun 2008 10:59] Sven Sandberg
Description:
TEST: rpl.rpl_dual_pos_advance 'mix'

The test failed with the following error:

rpl.rpl_dual_pos_advance 'mix' [ fail ]

--- /data0/pushbuild/pb/bzr_mysql-6.0/9/mysql-6.0.6-alpha-pb9/mysql-test/suite/rpl/r/rpl_dual_pos_advance.result	2008-06-19 12:44:59.000000000 +0300
+++ /data0/pushbuild/pb/bzr_mysql-6.0/9/mysql-6.0.6-alpha-pb9/mysql-test/suite/rpl/r/rpl_dual_pos_advance.reject	2008-06-19 16:06:54.000000000 +0300
@@ -15,6 +15,9 @@
 t1
 t2
 create table t3 (n int) engine=innodb;
+Warnings:
+Warning	1286	Unknown table engine 'innodb'
+Warning	1266	Using storage engine MyISAM for table 't3'
 set @a=1;
 insert into t3 values(@a);
 begin;

mysqltest: Result content mismatch

Stopping All Servers

How to repeat:
 WHERE: 6.0/joerg on Wed Jun 18 19:46:29 2008/'sapsrv2' -max/n_mix
 URL: https://intranet.mysql.com/secure/pushbuild/showpush.pl?dir=bzr_mysql-6.0&order=9
[11 Aug 2008 18:15] Serge Kozlov
The issue is based on 'disk is full' error on that host thus innodb plugin was skipped.

CURRENT_TEST: rpl.rpl_dual_pos_advance
InnoDB: The first specified data file ./ibdata1 did not exist:
InnoDB: a new database to be created!
080619 16:05:53  InnoDB: Setting file ./ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
080619 16:05:53  InnoDB: Log file ./ib_logfile0 did not exist: new to be created
InnoDB: Setting log file ./ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
080619 16:05:53  InnoDB: Error: Write to file ./ib_logfile0 failed at offset 0 1048576.
InnoDB: 1048576 bytes should have been written, only 892928 were written.
InnoDB: Operating system error number 22.
InnoDB: Check that your OS and file system support files of this size.
InnoDB: Check also that the disk is not full or a disk quota exceeded.
InnoDB: Error number 22 means 'Invalid argument'.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/operating-system-error-codes.html
InnoDB: Error in creating ./ib_logfile0: probably out of disk space
080619 16:05:53 [ERROR] Plugin 'InnoDB' init function returned error.
080619 16:05:53 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
/data0/pushbuild/pb/bzr_mysql-6.0/9/mysql-6.0.6-alpha-pb9/sql/mysqld: Disk is full writing '/dev/shm/var-n_mix-120/log/slave-bin.000001' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
080619 16:06:53 [Note] Event Scheduler: Loaded 0 events
080619 16:06:53 [Note] /data0/pushbuild/pb/bzr_mysql-6.0/9/mysql-6.0.6-alpha-pb9/sql/mysqld: ready for connections.
Version: '6.0.6-alpha-pb9-log'  socket: '/dev/shm/pbtmp-n_mix-120/slave.sock'  port: 11202  MySQL Pushbuild Edition, build 9
080619 16:06:53 [Note] Slave I/O thread: connected to master 'root@127.0.0.1:11200',replication started in log 'FIRST' at position 4
080619 16:06:53 [Note] Slave SQL thread initialized, starting replication in log 'FIRST' at position 0, relay log '/dev/shm/var-n_mix-120/log/slave-relay-bin.000001' position: 4
080619 16:06:54 [Note] Slave: received end packet from server, apparent master shutdown: 
080619 16:06:54 [Note] Slave I/O thread: Failed reading log event, reconnecting to retry, log 'master-bin.000001' at postion 542
080619 16:06:54 [ERROR] Slave I/O: error reconnecting to master 'root@127.0.0.1:11200' - retry-time: 1  retries: 10, Error_code: 2013
080619 16:06:54 [Note] /data0/pushbuild/pb/bzr_mysql-6.0/9/mysql-6.0.6-alpha-pb9/sql/mysqld: Normal shutdown