Bug #37695 Assert failure in Falcon (SyncObject destructor) during shutdown
Submitted: 27 Jun 2008 14:29 Modified: 1 Sep 2008 9:35
Reporter: Øystein Grøvlen Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Server: Falcon storage engine Severity:S3 (Non-critical)
Version:mysql-6.0-backup OS:Any
Assigned to: Assigned Account CPU Architecture:Any

[27 Jun 2008 14:29] Øystein Grøvlen
A MTR test fails, if I run the following two tests in sequence:

>./mtr backup_tablespace backup_view_on_view

Both tests are reported as passed, but at the end, the test run reports:
mysql-test-run: WARNING: Got errors/warnings while running tests, please examine "/home/og136792/mysql/shared/mysql-6.0-backup-1/mysql-test/var/log/warnings" for details.

mysql-test-run: *** ERROR: there were failing test cases
[og136792@fimafeng09 mysql-test]$ cat var/log/warnings
master.err: main.backup_view_on_view: Attempting backtrace. You can use the following information to find out

Looking in master.err, you can see that it fails during shutdown:
080627 17:21:36 - mysqld got signal 6 ;

The cleaned-up call stack, looks as follows:
(Error::error(char const*, ...)+0xf0)[0x8555d6]
(Error::assertionFailed(char const*, int)+0x16)[0x855636]
(SyncObject::~SyncObject [in-charge]()+0x21)[0x81ba47]
(Transaction::~Transaction [in-charge deleting]()+0x1db)[0x82bd65]
(TransactionManager::~TransactionManager [in-charge]()+0x3b)[0x8b1fa9]
(Database::~Database [in-charge deleting]()+0x26f)[0x84a81f]
(StorageInterface::panic(handlerton*, ha_panic_function)+0x16)[0x808ed2]

The test failures are only observed on Linux, but the assert is observed on Solaris, but the test framework is not set up to detect errors there.

How to repeat:
>./mtr backup_tablespace backup_view_on_view

Tests can be found on mysql-6.0-backup branch.
[27 Jun 2008 14:32] Øystein Grøvlen
Note that of the two tests only backup_tablespace acesses falcon tables.  Still, the other test needs also to be run for the test failure to occur.
[28 Jun 2008 13:39] Sveta Smirnova
Thank you for the report.

Verified as described.
[12 Aug 2008 12:18] Øystein Grøvlen
After I fixed bug#36795 (in backup tree), I got this error every time I ran the described test case.  Note that you need the bug fix for bug#36795 in order to get this error.  This bug fix has not yet been pushed to main 6.0 tree.
[1 Sep 2008 9:35] Øystein Grøvlen
Duplicate of bug#33575.