Bug #37675 Reverse engineering doesn't store connection profiles
Submitted: 26 Jun 2008 19:22 Modified: 27 Jun 2008 14:19
Reporter: Alex Saavedra Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.0.22 SE OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[26 Jun 2008 19:22] Alex Saavedra
Description:
In the "Reverse Engineering Database" interface, there is a dropdown for "Stored connections". I create such a connection with the "+" button. Then, when I invoke the "Reverse Engineering Database" a second time, and I choose the stored connection, the credentials are not stored.

How to repeat:
- Database >> Reverse Engineer >> Stored connection dropdown: click on "+" 
- Fill-in a connection name (e.g. "MyConnection") 
- Fill-in the "Parameters" and "Advanced" tabs 
- Proceed with all reverse engineering wizard steps till completion (so far, so good)
- Now let's proceed again: Database >> Reverse Engineer >> Stored connection dropdown: select "MyConnection"

Result: the "Parameters" and "Advanced" tabs are filled with default options; no host, username, database, password are stored.
[27 Jun 2008 8:13] Sergei Tkachenko
Thank you for taking the time to write to us, but this is not a bug.

The '+' button stores currently set settings as named stored connection. So you need to set up connection settings first, then save them as stored connection. If you want to change settings of stored connection just save settings as stored connection with the same name. That will overwrite previous values.
[27 Jun 2008 14:19] Alex Saavedra
Understood. Then it makes more sense to replace the "+", "-" and "C" button texts with explicit ones: "Save, "Delete", "Clear" (there's enough room)