Bug #37299 SQL Scripts not included in Forward Engineering
Submitted: 10 Jun 2008 7:11 Modified: 21 Aug 2014 1:41
Reporter: Radboud Platvoet Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S4 (Feature request)
Version:5.0.23 OS:Microsoft Windows (XP SP2)
Assigned to: CPU Architecture:Any
Tags: forward engineer, SQL Scripts
Triage: Triaged: D5 (Feature request) / R3 (Medium) / E3 (Medium)

[10 Jun 2008 7:11] Radboud Platvoet
Description:
When I forward engineer my model to a database instance I am not able to select the SQL Scripts I have defined.

How to repeat:
Create a model.
Create some tables.
Create a SQL Script (for example with an insert statement).
Forward engineer to database.

Scripts are not executed because the insert is not in the database.

Suggested fix:
Allow selection of the SQL Scripts to be added to the forward engineering. Execute the SQL Scripts after Schema, Tables, Relationships, Triggers, Views, etc have been created.
[10 Jun 2008 11:36] Miguel Solorzano
Thank you for the bug report. This behavior is by design.
[11 Jun 2008 7:14] Radboud Platvoet
That's too bad. IT would be really nice to be able to select the SQL scripts that you want to include in the forward engineering process. Why else would one want to save a sql script as part of the model?
[4 Aug 2008 11:08] Mike Lischke
Actually a nice idea: execute selected SQL scripts when doing the forward engineering. Let's keep this as a feature wish.
[26 Jun 2014 19:52] Alfredo Kojima
Posted by developer:
 
An option to include scripts in forward engineer and synchronize was added.
[21 Aug 2014 1:41] Philip Olson
Fixed as of the MySQL Workbench 6.2.0 release, and here's the changelog entry:

An option to include (attach) SQL scripts was added in the forward
engineer and synchronization wizards.

Thank you for the bug report.