Bug #37085 client crashes on empty input
Submitted: 29 May 2008 22:54 Modified: 30 May 2008 11:24
Reporter: Alex Efros Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:5.0.54/5.1/6.0 OS:Linux (Hardened Gentoo)
Assigned to: CPU Architecture:Any
Tags: segfault
Triage: D4 (Minor)

[29 May 2008 22:54] Alex Efros
Description:
MySQL command-line client crashes with segfault on empty input.

How to repeat:
home ~ # mysql -u test </dev/null
Segmentation fault
home ~ # echo -n | mysql -u test           
Segmentation fault
home ~ # echo | mysql -u test
home ~ #
[29 May 2008 23:48] Miguel Solorzano
Thank you for the bug report.

[miguel@hegel dbs]$ 5.1/bin/mysql -u test </dev/null
Segmentation fault
[miguel@hegel dbs]$ 5.0/bin/mysql -u test </dev/null
Segmentation fault
[miguel@hegel dbs]$ 6.0/bin/mysql -u test </dev/null
Segmentation fault
[miguel@hegel dbs]$
[30 May 2008 11:24] Domas Mituzas
Duplicate of Bug#35480