Bug #36977 sql_low_priority_updates_func.test fails in pushbuild
Submitted: 26 May 2008 15:10 Modified: 15 Oct 2012 14:07
Reporter: Ingo Strüwing Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Server Severity:S3 (Non-critical)
Version:5.1.26, 6.0-engines OS:Linux
Assigned to: CPU Architecture:Any
Triage: D3 (Medium)

[26 May 2008 15:10] Ingo Strüwing
Description:
Seen on debx86-b in 6.0-engines-merge:

main.sql_low_priority_updates_func [ fail ]

ERROR: mysqltest returned unexpected code 139, it has probably crashed

I will disable the test case for now. Please re-enable after fix.

How to repeat:
See pushbuild.
[18 Jun 2008 16:43] Thava Alagu
The problem is not reproducible in the latest snapshot of 6.0-engines-merge tree. As this tree is obsolete now, reenabling the test is not necessary. I also verified this test is not disabled in 6.0 main tree.
[30 Jun 2008 19:34] Joerg Bruehe
The problem seems to be an intermittent one:

Of more than 210 runs of this test in "embedded" mode in the build of 5.1.26, I had it fail in 19.

I cannot spot a system in the platform/configuration list:
RPM, RHAS3, IA64 (icc)   advanced
RPM, RHAS3, IA64         community
RPM, RHAS3, x86          advanced
RPM, RHAS3, x86          community
RPM, RHAS3, x86          enterprise-gpl
RPM, RHAS3, x86          enterprise
RPM, RHAS3, amd64        advanced-gpl
RPM, RHAS3, amd64        advanced
RPM, RHAS3, amd64        community
RPM, RHAS3, amd64        community
RPM, RHAS3, amd64        enterprise-gpl
RPM, RHAS3, amd64        enterprise
Linux, amd64 (icc)       advanced
Linux, amd64             advanced
Linux, amd64             community
Linux, amd64             enterprise
Linux, x86               advanced
Linux, x86               community
Linux, x86               enterprise

Note that this starts in 5.1 !
[21 Aug 2008 21:19] Thava Alagu
Looks like this test was never meant to work with embedded mode.
The following change was checked into the source on june 18th that 
should have gracefully skipped this test on embedded mode testing.
Hence this should no longer be an issue and I will be closing this bug.

 bzr diff  -c 2652 sql_low_priority_updates_func.test
=== modified file 'mysql-test/t/sql_low_priority_updates_func.test'
--- mysql-test/t/sql_low_priority_updates_func.test     2008-04-10 13:14:28 +0000
+++ mysql-test/t/sql_low_priority_updates_func.test     2008-06-18 16:17:15 +0000
@@ -19,6 +19,7 @@
 #                                                                             # ############################################################################### +--source include/not_embedded.inc

 ################################################################
 # sql_low_priority_updates was renamed to low_priority_updates #
[15 Oct 2012 14:07] Erlend Dahl
Fixed in later versions of 5.1