Bug #36967 rpl_foreign_key_innodb.test fails in pusbuild
Submitted: 26 May 2008 14:24 Modified: 8 Dec 2010 19:18
Reporter: Ingo Strüwing Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Tests: Replication Severity:S3 (Non-critical)
Version:6.0-engines-merge OS:Any
Assigned to: Serge Kozlov CPU Architecture:Any
Tags: pushbuild, sporadic, test failure
Triage: D3 (Medium)

[26 May 2008 14:24] Ingo Strüwing
Description:
Seen on sapsrv1 in 6.0-engines-merge:

rpl.rpl_foreign_key_innodb 'mix' [ fail ]

mysqltest: In included file "./include/master-slave.inc": At line 6: query 'connect  slave,127.0.0.1,root,,test,$SLAVE_MYPORT,' failed: 2003: Can't connect to MySQL server on '127.0.0.1' (111)

And server logs:

WARNING:  'Attempting backtrace. You can use the following information to find out'
    COUNT: 1
    FILES:    slave.err
    TESTS:    rpl.rpl_foreign_key_innodb

WARNING:  'slave.err: rpl.rpl_foreign_key_innodb: Attempting backtrace. You can use the following information to find out'
    COUNT: 1
    FILES:    warnings
    TESTS:    <unknown>

I will disable the test case for now. Please re-enable after fix.

How to repeat:
See pushbuild.
[27 May 2008 13:02] Sveta Smirnova
Thank you for the report.

I can not repeat it on my side.
[27 May 2008 13:29] Ingo Strüwing
Ok. But did you re-enable the test case?
[28 Jun 2008 15:26] Sven Sandberg
Magnus said, when looking at another pushbuild failure: sol10-amd64-a is very slow and new mtr.pl has "start_timeout" set to 30 seconds instead of the old 400 seconds(which I believe is too long). Will increase the value to a reasonable value and add a printout when this happens.

The failure in the present bug looks like it could be caused by this as well. So let's wait until Magnus pushes his work.
[28 May 2009 11:18] Christoffer Hall
This failure now pops up on my machine. With 100% reproducability. It can currently be found in the mysql-5.0-bugteam tree.
[28 May 2009 13:19] Christoffer Hall
This now pops up in 5.1-bugteam as stated above. Exactly the same.
[25 Feb 2010 10:25] Luis Soares
See also BUG#48304, which may be a duplicate of this one.