Bug #36820 MyODBC Driver on Mac OS X not able to create 'System' DSN
Submitted: 20 May 2008 16:05 Modified: 22 May 2008 21:06
Reporter: Charlie Boisseau Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:3.51.25 OS:Mac OS X
Assigned to: CPU Architecture:Any
Tags: ODBC System DSN

[20 May 2008 16:05] Charlie Boisseau
Description:
When using the MyODBC Driver on Mac OS X's ODBC Administratior application, any attempt to create a 'System DSN' (as opposed to a 'User DSN') always saves the settings under 'User DSN'.  This means that processes not running from the currently logged in user (including any server services) cannot use the DSN.

Having looked at the configuration of the driver in ODBC Administrator, it is correctly set to 'Define as: System', however changing this setting one way or the other does not resolve the problem.

Tested the exact same setup using the 'Actual' (brand) ODBC driver, and it works perfectly.

How to repeat:
 - Download MyODBC 3.51.25 for Mac OS X
 - Double Click on the DMG file to mount the disk image.
 - Open the installer and follow installation instructions.
 - Once installed, open 'ODBC Administrator' from /Applications/Utilities/
 - Check the driver is appearing under the 'Drivers' tab.
 - Click on the 'System DSN' tab, and make sure the padlock in the bottom left is unlocked.
 - Click 'Add' button (top right), Select the MySQL ODBC Driver.
 - Enter valid details for a MySQL connection and give it a DSN Name.
 - Click the OK button on the configuration window.
 - Click 'Apply' on the ODBC Administrator window.
 - Note that the DSN has not appeared under 'System DSN'
 - Click onto 'User DSN' and you should find your newly created entry.
[21 May 2008 18:20] Sveta Smirnova
Thank you for the report.

It looks like duplicate of bug #31495 which should be fixed in version 3.51.25.

But please note a note from the indicated bug report:

ODBC Administrator may still be unable to register a System DSN unless the /Library/ODBC/odbc.ini file has the correct permissions. You should ensure that the file is writable by the admin group.

Please check permissions of file /Library/ODBC/odbc.ini and provide us result (ls -l /Library/ODBC/odbc.ini).
[21 May 2008 19:02] Charlie Boisseau
Sveta,

I have changed the permissions, however it hasn't solved the problem:

-rw-rw-r--   1 filemake  admin  38 May 20 16:25 /Library/ODBC/odbc.ini

Any idea of when the 3.51.24/3.51.25 release will be available?

Thanks.
[22 May 2008 19:03] Sveta Smirnova
Thank you for the feedback.

> Any idea of when the 3.51.24/3.51.25 release will be available?

Version 3.51.25 is available for download at http://dev.mysql.com/downloads/connector/odbc/3.51.html.

Also you indicated version 3.51.25 in bug details. Which version do you use really?
[22 May 2008 20:15] Charlie Boisseau
Apologies for the confusion.. I have checked the installed version is indeed 3.51.25, which would indicate the problem was not fixed in this release.  Can you confirm this?
[22 May 2008 21:06] Sveta Smirnova
Thank you for the feedback.

Yes, I can confirm error still exists in version 3.51.25. So I reopened bug #31495. This one is duplicate of bug #31495.
[22 May 2008 21:28] Sveta Smirnova
The workaround is to use the command-line myodbc3i or myodbc-installer utility for creating system dsns.