Bug #36741 I have just upgraded from 5.1.5 -> 5.1.6, and now when I close my application
Submitted: 15 May 2008 19:24 Modified: 16 May 2008 10:20
Reporter: zinnko zeis Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:5.1.6 OS:Microsoft Windows (server 2003)
Assigned to: CPU Architecture:Any
Tags: SemaphoreFullException

[15 May 2008 19:24] zinnko zeis
Description:
Using:

Server : Ubuntu Server 6.0.02
Language programming : Visual Studio C#
Clients : Windows XP - server 2003 - Vista
MySQL Database Server : MySQL version 5.0.22

No se controló System.Threading.SemaphoreFullException
  Message="Al agregar un recuento dado al semáforo hará que se supere el recuento máximo."
  Source="System"
  StackTrace:
       en System.Threading.Semaphore.Release(Int32 releaseCount)
       en System.Threading.Semaphore.Release()
       en MySql.Data.MySqlClient.MySqlPool.RemoveConnection(Driver driver)
       en MySql.Data.MySqlClient.MySqlPoolManager.RemoveConnection(Driver driver)
       en MySql.Data.MySqlClient.NativeDriver.Dispose(Boolean disposing)
       en MySql.Data.MySqlClient.Driver.Close()
       en MySql.Data.MySqlClient.NativeDriver.Finalize()

How to repeat:
Installing MySQL Connector/Net 5.1.6
[16 May 2008 10:20] Tonci Grgin
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Explanation: This is a duplicate of Bug#36688.