Bug #36727 Critcal program errors during install/uninstall
Submitted: 14 May 2008 22:49 Modified: 15 May 2008 7:46
Reporter: Olle Pesson Email Updates:
Status: Can't repeat Impact on me:
Category:MySQL Server Severity:S1 (Critical)
Version:5.0.51b OS:Windows (XP sp3)
Assigned to: CPU Architecture:Any
Tags: ?

[14 May 2008 22:49] Olle Pesson
Ive ran into some serious bugs with the install/uninstall procedure of mysql. I first installed a broken mysql, removed it using windows add/remove programs. I removed everything from the program files folder. Ive also used a reg cleaner which removed the traces left of the program. 

The thing is when im trying to install a new mysql i get all kinds of weird errors cannot start service: error 0, fatal error, critical network error and blah blah. Here i am now with a horrible bugged program which i cant install in any way, ive got no idea where this program is actually hiding in the system but its still there. Ive removed the it from services, ive removed traces in the registry. For some reason its still around and messes with any other installs of the program.

How to repeat:
How to repeat? just trying to install any mysql and the problems appears over and over again. 

Suggested fix:
Reinstalling windows, that would probably work. This is totally unacceptable by a modern program, especially one in the scale of mysql.
[14 May 2008 23:02] Peter Laursen
Now - come down please!  There must be some issue with your system.  Too much 'fiddling' with the registry maybe? Or a hardware issue?

Please realize that if this was a common problem with MySQL there would be hundreds/thousands of such reports every week!  There is not a single similar one! 

(not a mysql person)
[14 May 2008 23:48] Olle Pesson
Yeah... of course its "my" fault. I make a living breaking programs having them showing me fancy errors, because i just love it!

I havent had an uninstall like this in YEARS, it was like trying to get rid of a trojan. In the end i succeeded of course and found the problem. Which in this case was caused by nod32/comodo. 

Still nod32/comodo had nothing to do with the uninstall procedure of mysql 5.x that was the program causing a huge amount of problems and *not* actually uninstalling when asked to. It was *still* left in the system after a so-called uninstall and we all know what type of software that normally does that is called...

My point being: Why would *you* care what someone like me has to say, since, using your words "im one of the few who experienced this".

The program could have detonated my computer but who would care since im the only one with the problem. Heck mysql could probably turn my computer into a nuclear bomb! at that point we'd all have a laugh i assure you!
[15 May 2008 7:46] Susanne Ebrecht
Many thanks for writing a bug report.

Unfortunately I can't repeat this. I tried to install / deinstall MySQL more then 50 times and it worked fine.