Bug #36697 MySQL Migration Toolkit / GRT wont start on Windows XP (JRE 1.6.0_06)
Submitted: 13 May 2008 18:27 Modified: 13 May 2008 19:06
Reporter: Cees Hesp Email Updates:
Status: Closed Impact on me:
Category:MySQL Migration Toolkit Severity:S1 (Critical)
Version:1.1.12 / 2.0.12 (GRT) OS:Windows
Assigned to: CPU Architecture:Any

[13 May 2008 18:27] Cees Hesp
When starting the MySQL Migration Toolkit (1.1.12), it reports:

An error occured during initialization of the runtime system. Please make sure you have the Java Runtime Environment (JRE) 5.0 update 8 installed.

and if I look in the GRT Shell (2.0.12), is says:

ERROR: Could not load java class com/mysql/grt/Grt.

I updated my JRE today, and it's now on version 1.6.0_06.

Similar problems were reported before (21823,27887) but disappeared rather than fixed.

How to repeat:
Choose [Start], [All Programs], [MySQL], [MySQL Migration Toolkit]
[13 May 2008 19:06] Cees Hesp
First tried adding "C:\Program Files\Java\jre1.6.0_06\bin" to the PATH, and then rebooting the machine, but this did not help.

What did help was removing all "old" versions of the JRE. Now it works fine.