Bug #36695 'max_heap_table_size_basic' Failed: Var can get values greater as described.
Submitted: 13 May 2008 16:25 Modified: 25 Jun 2009 10:29
Reporter: Horst Hunger Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.1.25-rc OS:Microsoft Windows (win2003 64bit)
Assigned to: Assigned Account CPU Architecture:Any

[13 May 2008 16:25] Horst Hunger
Description:
On 'vm-win2003-64-b' Win64 VS2005 -max-nt the test 'max_heap_table_size_basic_32' seems to fail due to a bug in the server. Assumed reason is a 32-bit build on 64 bit machine which might not be implemented well. Means the behaviour of the system variable depends on the machine and not on the build. I am nor sure if variables in a 32 bit build may get 64 bit values. See following excerpt of log:

main.max_heap_table_size_basic_32 [ fail ]

--- C:/cygwin/home/pushbuild/pb1/pb/mysql-5.1-bugteam/59/mysql-5.1.25-rc-pb59/mysql-test/r/max_heap_table_size_basic_32.result	2008-05-13 15:55:47.000000000 +0300
+++ C:\cygwin\home\pushbuild\pb1\pb\mysql-5.1-bugteam\59\mysql-5.1.25-rc-pb59\mysql-test\r\max_heap_table_size_basic_32.reject	2008-05-13 16:51:39.193625000 +0300
@@ -98,17 +98,17 @@
 SET @@global.max_heap_table_size = 4294967296;
 SELECT @@global.max_heap_table_size;
 @@global.max_heap_table_size
-4294966272
+4294967296
 SET @@global.max_heap_table_size = 65530.34.;
 ERROR 42000: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '.' at line 1
 SELECT @@global.max_heap_table_size;
 @@global.max_heap_table_size
-4294966272
+4294967296
 SET @@global.max_heap_table_size = test;
 ERROR 42000: Incorrect argument type to variable 'max_heap_table_size'
 SELECT @@global.max_heap_table_size;
 @@global.max_heap_table_size
-4294966272
+4294967296
 SET @@session.max_heap_table_size = -1;
 Warnings:
 Warning	1292	Truncated incorrect max_heap_table_size value: '0'
@@ -124,19 +124,19 @@
 SET @@session.max_heap_table_size = 4294967296;
 SELECT @@session.max_heap_table_size;
 @@session.max_heap_table_size
-4294966272
+4294967296
 SET @@session.max_heap_table_size = 65530.34.;
 ERROR 42000: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '.' at line 1
 SET @@session.max_heap_table_size = 10737418241;
 SELECT @@session.max_heap_table_size;
 @@session.max_heap_table_size
-4294966272
+10737418240
 'Bug # 34837: Errors are not coming on assigning invalid values to variable';
 SET @@session.max_heap_table_size = test;
 ERROR 42000: Incorrect argument type to variable 'max_heap_table_size'
 SELECT @@session.max_heap_table_size;
 @@session.max_heap_table_size
-4294966272
+10737418240
 '#------------------FN_DYNVARS_077_06-----------------------#'
 SELECT @@global.max_heap_table_size = VARIABLE_VALUE 
 FROM INFORMATION_SCHEMA.GLOBAL_VARIABLES 

mysqltest: Result content mismatch

Stopping All Servers
Restoring snapshot of databases
Resuming Tests

How to repeat:
run the test on win2003 64 bit with a 32 bit build.
[14 Sep 2008 16:10] Valeriy Kravchuk
Please, try to repeat with a newer version, 5.1.28, and inform about the results.
[14 Oct 2008 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[25 Jun 2009 10:29] Jon Olav Hauglid
Duplicate of Bug#36877