Bug #3668 Both installers fail with error: Internal Error 2727 INSTALLDIR
Submitted: 5 May 2004 20:55 Modified: 20 Jul 2004 1:31
Reporter: James Tokach Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51.07 OS:Microsoft Windows (Windows XP)
Assigned to: Timothy Smith CPU Architecture:Any

[5 May 2004 20:55] James Tokach
Description:
I have version 3.51.06 installed.  I just download the 3.51.07 and tried to install.  Both the .EXE and the .MSI return the same error.  It's noteworthy to mention that the installer seems to think this version is installed already as it gives me the MODIFY, REPAIR and UNINSTALL options rather than the INSTALL option.

How to repeat:
Install 3.51.06 then try to install 3.51.07

Suggested fix:
I'm not fond of the WISE installer for various reasons, but I doubt MySQL is going to change to a quality product on my account. =)  Double check the install routine.
[5 May 2004 20:56] James Tokach
By the way, I did verify the current installed version as being 3.51.06 several times throughout this process.
[8 May 2004 4:58] Miguel Solorzano
I wasn't able for to repeat the behavior reported on Win XP.
[8 May 2004 5:36] Miguel Solorzano
I got the screen:

MySQL Connector/ODBC has
been successfully installed.

from the 3.51.07's installer but the driver 3.51.06 wasn't upgraded:

C:\>dir d:\win\system32\myodbc*.dll
 O volume na unidade D é Disk E
 O número de série do volume é 0C76-F6B4

 Pasta de d:\win\system32

04/03/2003  00:22           360.448 myodbc3.dll
04/03/2003  00:56           700.469 myodbc3d.dll
               2 arquivo(s)      1.060.917 bytes
               0 pasta(s) 15.344.173.056 bytes disponíveis

still the older files.

Then I tested on clean Win2k Server and the correct file
was installed:

C:\>dir c:\winnt\system32\myodbc*.dll
 O volume na unidade C não tem nome.
 O número de série do volume é 3C2A-26E8

 Pasta de c:\winnt\system32

31/03/2004  01:30              385.024 myodbc3.dll
               1 arquivo(s)        385.024 bytes
               0 pasta(s) 20.925.440.000 bytes disponíveis

So the Installer has failed for to upgrade the older 3.51.06
driver.

Thank you for the bug report.
[24 Jun 2004 18:44] Peter Harvey
removing from PGalbraith
[12 Jul 2004 23:54] Peter Harvey
MyODBC v3.51.7 was released with the drivers internal version incompletely updated. MyODBC v3.51.8 should show the correct version and also install properly.
[20 Jul 2004 1:31] Timothy Smith
Thank you for your bug report. This issue has already been fixed
in the latest released version of that product, which you can download at 
http://www.mysql.com/downloads/

Additional info:

This was fixed in release 3.51.08