Bug #35911 mysql.servers not included in 5.1.23?
Submitted: 8 Apr 2008 20:01 Modified: 8 Apr 2008 20:38
Reporter: Roland Bouman Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:5.1.23 OS:Microsoft Windows (XP Pro)
Assigned to: CPU Architecture:Any

[8 Apr 2008 20:01] Roland Bouman
Description:
On a completely fresh install of MySQL 5.1.23 on a pristine Windows XP Pro box, i get this in the error log:

080408 21:24:37  InnoDB: Started; log sequence number 0 2397717
080408 21:24:37 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
080408 21:24:37 [Note] Event Scheduler: Loaded 0 events
080408 21:24:37 [Note] E:\MySQL_5_1_23\bin\mysqld: ready for connections.
Version: '5.1.23-rc-community'  socket: ''  port: 3351  MySQL Community Server (GPL)

Indeed - the servers table is not present in the mysql database.

How to repeat:
Install MySQL 5.1.23 on a fresh windows machine. Run server.

Suggested fix:
create servers table
[8 Apr 2008 20:38] MySQL Verification Team
Thank you for the bug report. Duplicate of bug: http://bugs.mysql.com/bug.php?id=32797