Bug #35890 could not start server service after installing windows msi package
Submitted: 8 Apr 2008 5:47 Modified: 5 May 2009 5:21
Reporter: Erica Moss Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Config Wizard Severity:S1 (Critical)
Version:5.0.51a, 5.1 OS:Microsoft Windows (xp sp2)
Assigned to: Assigned Account
Tags: windows my.ini
Triage: Triaged: D3 (Medium)

[8 Apr 2008 5:47] Erica Moss
Description:
During the "start service" phase of the configuration wizard, received error:

"Could not start the service MySQL. Error:0

How to repeat:
1) Installed 5.0.45 setup zip package
2) setup my.ini as follows and worked with installation
[mysqld]
max_allowed_packet=64M
enable-named-pipe
enable-shared-memory

(Not certain whether this is a necessary part of the scenario or not but it doesn't seem so)

3) Backed up my.ini before running intall
4) Ran uninstall wizard
5) verified server service instance removed
6) Started mysql-essential-5.0.51a-win32.msi
7) Selected complete install
8) Selected Standard Configuration
9) My.Ini is recreated

Results:
During the "start service" phase of the configuration wizard, received error:

"Could not start the service MySQL. Error:0"

11) Tried to start the service manually 
  a) right click on "My Computer"
  b) select "Manage"
  c) select "Services"
  d) select MySQL
  e) select "Start"

Results: 
received error: "Error 1067: The process terminated unexpectedly"

12) copied backup of my.ini from previous 5.0.45 installation
13) Again tried starting the server service manually

Results:
Service started successfully

This same sequence was tried twice and the results were identical.  It appears there may be some corruption in the ini file template in the .51 package  Both files are attached.
[8 Apr 2008 5:48] Erica Moss
my.ini from 5.0.45 install package

Attachment: my.ini (application/octet-stream, text), 9.10 KiB.

[8 Apr 2008 5:49] Erica Moss
5.0.51a my.ini version

Attachment: my.ini from installation of 51 (application/octet-stream, text), 9.03 KiB.

[8 Apr 2008 20:02] Erica Moss
As mentioned in the steps, the workaround for this is to have a copy of the old my.ini file saved and to overwrite the one that is created at install time

I tried running the .58 enterprise installer and it did not have the same problem
[10 Apr 2008 17:46] Erica Moss
Update:
The 5.0.58 package which I had installed which was able to successfully start was
mysql-classic-5.0.58-win32.zip

After running uninstall on that package and then installing mysql-enterprise-5.0.58-win32.zip, I once again encountered the exact same problem.  I was only able to get the service started again by overwriting the current my.ini file with an older copy.
[25 Apr 2008 4:57] Erica Moss
I looked into this a bit more.  It appears that the value in the config file that is breaking this installation is:
innodb_log_file_size=24M

The existing data files on this system are 10M and the old my.ini file reflects this.  I can't say with any certainty what server version these data files were created under as this data dir has been there for quite a while.  I'm also not sure what manner of configuration was used to arrive at a size of 10M.

The new size of 24M is arrived at when "standard configuration" is selected in 5.0.58.

After discussing this issue with IggyG, it seems like the best fix would be to NOT remove an existing my.ini file during server uninstall.  Then the installer would read that file and use the existing values when creating the new file.

It is a big problem for a user if the new installation can't start because of the configuration values the installer chose, and with the old ini file deleted, it would be very hit or miss for a user to try to isolate which value needs to be modified to resolve the problem.

Another possible fix might be to look for an existing data directory during installation, and establish the value of that variable based upon the known size of existing innodb log files.

In either event, it would be very helpful to users if this mismatch condition could be checked for when the server is starting, and return an actual error message that describes the problem, rather than Error 0.  It would have made it much easier and faster to resolve.
[27 Feb 2009 15:32] Hans Geerdink
I
[27 Feb 2009 15:33] Hans Geerdink
I have just downloaded my first ever MySQL msi installer and have to conclude this bug is still present!
I am using Windiws Advanced Server 2003 SP1 R2 and had never had MySQL installed on any of my machines, still the problem of the service not able to start exists.

Windows event viewer:
Error- Source:MySQL Category:None EventID:100
Plugin 'InnoDB' init function returned error.

Error- Source:MySQL Category:None EventID:100
Plugin 'InnoDB' registration as a STORAGE ENGINE failed.

Error- Source:MySQL Category:None EventID:100
Unknown/unsupported table type: INNODB

Error- Source:MySQL Category:None EventID:100
Aborting

Warning- Source:MySQL Category:None EventID:100
Forcing shutdown of 1 plugins

I am Using mysql-5.1.31-win32.msi, at the configuration stage it keeps telling me something with the initialisation of the InnoDB.... beats me!
[5 May 2009 5:21] Susanne Ebrecht
I will set this as duplicate of bug #42820 because there are more detailed informations.