Bug #35739 Generate Schema Diff Report throws exception
Submitted: 1 Apr 2008 12:14 Modified: 24 Jun 2008 9:23
Reporter: Christian Kaspar Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.0.22 OS:Microsoft Windows (XP SP 2)
Assigned to: Mike Lischke CPU Architecture:Any
Triage: D1 (Critical)

[1 Apr 2008 12:14] Christian Kaspar
Description:
I tried to generate a schema diff report. After selecting the database I recieve each time an unhandled exception.

How to repeat:
further information:
error message in attached screen shot and output of debugger
[1 Apr 2008 12:15] Christian Kaspar
debugger output

Attachment: workbench-error.txt (text/plain), 7.86 KiB.

[1 Apr 2008 12:15] Christian Kaspar
error message

Attachment: Workbench-Error.jpg (image/pjpeg, text), 26.27 KiB.

[1 Apr 2008 12:47] Miguel Solorzano
Thank you for the bug report.

************** Texto de Exceção **************
System.AccessViolationException: Tentativa de leitura ou gravação em memória protegida. Normalmente, isso é uma indicação de que outra memória está danificada.
   em DbMySQLDiffReporting.generate_report(DbMySQLDiffReporting* , basic_string<char\,std::char_traits<char>\,std::allocator<char> >* , basic_string<char\,std::char_traits<char>\,std::allocator<char> >* , basic_string<char\,std::char_traits<char>\,std::allocator<char> >* , MYX_GRT_VALUE* , MYX_GRT_VALUE* )
   em MySQL.GUI.Workbench.Plugins.DbMySQL.DbMySQLDiffReporting.generate_report(String left_file, String right_file, GrtValue left_cat, GrtValue right_cat)
   em MySQL.GUI.Workbench.Plugins.DbMySQL.DiffReportingWizardPages.InitGeneratedScriptPage()
   em MySQL.GUI.Workbench.Plugins.WizardPlugin.InitializeActivePage()
   em MySQL.GUI.Workbench.Plugins.WizardPlugin.UpdateAfterPageProcessing(String errMsg)
   em MySQL.GUI.Workbench.Plugins.WizardPlugin.RestoreControlsState(String errMsg)
   em MySQL.GUI.Workbench.Plugins.WizardPlugin.GoToNextPage()
   em MySQL.GUI.Workbench.Plugins.WizardPlugin.btnNext_Click(Object sender, EventArgs e)
   em System.Windows.Forms.Control.OnClick(EventArgs e)
<cut>
[2 Apr 2008 10:38] Mike Lischke
I cannot reproduce this problem with the current code, so it might already be fixed. Please test again with the next release, as soon as it is available and let me know if you still see the crash. If that is the case then I'd also appreciate if you could add a sample model and exact steps to reproduce (including setting up the initial schema against you have compared).
[2 May 2008 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[24 Jun 2008 9:23] Christian Kaspar
Generate Schema Diff Report works with version 5.0.22