Bug #35680 negative values appereas in memory status log on sighup
Submitted: 30 Mar 2008 9:09 Modified: 30 Mar 2008 11:27
Reporter: Vadim Smelyansky Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Logging Severity:S3 (Non-critical)
Version:5.0.51a OS:Linux (x86_64)
Assigned to: CPU Architecture:Any
Tags: negative values, STATUS

[30 Mar 2008 9:09] Vadim Smelyansky
Description:
issuing a SIGHUP signal producing negative values in memory status report like below:
Memory status:
Non-mmapped space allocated from system: 64901120
Number of free chunks:                   82
Number of fastbin blocks:                0
Number of mmapped regions:               8
Space in mmapped regions:                -1609015296
Maximum total allocated space:           0
Space available in freed fastbin blocks: 0
Total allocated space:                   882688
Total free space:                        64018432
Top-most, releasable space:              54460272
Estimated memory (with thread stack):    -1541492736

How to repeat:
killall -1 mysqld

Suggested fix:
probably int or signed long type should be replaced with unsigned long
[30 Mar 2008 11:27] Shane Bester
this is a duplicate of bug #27854