Bug #35677 Constant "crash" in MySQL Workbench 5.0.16 RC
Submitted: 30 Mar 2008 0:38 Modified: 8 Apr 2008 14:33
Reporter: Daniel Bentley Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.0.16 OS:Microsoft Windows (Vista 32-bit)
Assigned to:

[30 Mar 2008 0:38] Daniel Bentley
Description:
See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.
Had this problem in 5.0.13 and in 5.0.16, but did not have this problem in 5.0.15

Program keeps "crashing" with the following error report. I can continue working, however the crash keep returning repeatedly. It seems to be linked to the Diagram drawingarea, as it mostly occurs when the mouse is over that area (even if no interaction is happening)

The crash also happens with the mouse over the thumbnail area (including the scale selector)

************** Exception Text **************
System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at bec.GRTManager.flush_timers(GRTManager* )
   at MySQL.Workbench.WbContext.flush_timers()
   at MySQL.GUI.Workbench.MainForm.timer_Tick(Object sender, EventArgs e)
   at System.Windows.Forms.Timer.OnTick(EventArgs e)
   at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
MySQLWorkbench
    Assembly Version: 5.0.16.2874
    Win32 Version: 5.0.16.2874
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/MySQLWorkbench.exe
----------------------------------------
wb.wr
    Assembly Version: 0.0.0.0
    Win32 Version: 
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/wb.wr.DLL
----------------------------------------
grt.wr
    Assembly Version: 0.0.0.0
    Win32 Version: 
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/grt.wr.DLL
----------------------------------------
System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
MySQLCsUtilities
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/MySQLCsUtilities.DLL
----------------------------------------
msvcm80
    Assembly Version: 8.0.50727.1434
    Win32 Version: 8.00.50727.1434
    CodeBase: file:///C:/Windows/WinSxS/x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.1434_none_d08b6002442c891f/msvcm80.dll
----------------------------------------
MySQLGrtShell
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/MySQLGrtShell.EXE
----------------------------------------
WeifenLuo.WinFormsUI.Docking
    Assembly Version: 2.2.3007.11795
    Win32 Version: 2.2.0.0
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/WeifenLuo.WinFormsUI.Docking.DLL
----------------------------------------
System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
MySQLWorkbenchEditors
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/MySQLWorkbenchEditors.DLL
----------------------------------------
Accessibility
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
Aga.Controls
    Assembly Version: 1.6.0.0
    Win32 Version: 1.6.0.0
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/Aga.Controls.DLL
----------------------------------------
grt.helpers.be
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.0%20OSS/grt.helpers.be.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

How to repeat:
Just wait, it happens repeatedly, with or without any interaction

Suggested fix:
not a clue, had this problem in DBDesigner4 and in MySQL Workbench 5.0.13 (didn't use earlier versions), everything worked fine in 5.0.15, then here it returns in 5.0.16
[30 Mar 2008 5:40] Daniel Bentley
Discovered the problem.
Back in 5.0.13 I was having problems with the Referenced Column field in Foreign Keys. I would set the fields, but they wouldn't take sometimes for undeterminate reasons.

I did an SQL dump of my tables, then re-imported them into a blank schema, and it pointed out the bad tables. Went and fixed these broken references and the crash no longer occurs.
[31 Mar 2008 18:06] Valerii Kravchuk
Thank you for a problem report. Can you, please, be more specific on how to repeat this problem, if you still consider it a bug in Workbench. Upload problematic schema or give some other exact steps to repeat the problem each and every time.
[1 Apr 2008 2:37] Daniel Bentley
as I said in my second comment... the bug is caused by the Referenced Column field being blank
[4 Apr 2008 16:58] Johannes Taxacher
Several issues were caused by invalid models like that. Loading/handling of models with invalid FK definitions has been improved to avoid crashing. Additionally, table editor has been improved so that this(leaving referenced field blank) shouldn't happen anymore.
[8 Apr 2008 14:33] MC Brown
A note has been added to the 5.0.17 changelog: 

Workbench would crash repeatedly when drawing the diagram for a table where the referenced column in a foreign key relationship was blank.