Bug #35614 ctype_hebrew test fails sporadically on vm-win2003-64-b
Submitted: 27 Mar 2008 15:37 Modified: 8 Dec 2008 10:03
Reporter: Alexey Kopytov Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Tests: Server Severity:S3 (Non-critical)
Version:5.1 OS:Microsoft Windows
Assigned to: Sergei Glukhov CPU Architecture:Any

[27 Mar 2008 15:37] Alexey Kopytov
Description:
There are random failures of the ctype_hebrew test on the vm-win2003-64-b host in PushBuild: https://intranet.mysql.com/secure/pushbuild/xref.pl?startdate=&enddate=&dir=&plat=vm-win20...

The problem cannot be reproduced by just running the failing test alone, it seems to depend on the previous tests execution.

From the log files it looks like the server hangs after the "SET NAMES HEBREW" statement until the testcase timeout (15 minutes by default) expires. Since we do not include .pdb files into our PB builds, getting a callstack from the server is pointless.

How to repeat:
Run the test suite on vm-win2003-64-b like this:

$ ./mysql-test-run.pl  --timer --force --skip-im --ps-protocol --mysqld=--binlog-format=row --start-from=ctype --verbose --script-debug --testcase-timeout=1
[8 Dec 2008 10:03] Sergei Glukhov
checked latest 5.1 tree, can't repeat