Bug #35603 Unhandled Exception when moving mouse after deleting a layer
Submitted: 27 Mar 2008 12:39 Modified: 8 Apr 2008 14:22
Reporter: Daniel Haas Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.0.16 RC OS:Microsoft Windows (Vista)
Assigned to: Alfredo Kengi Kojima

[27 Mar 2008 12:39] Daniel Haas
Description:
After deleting a layer in a diagram, and later clicking into the canvas I got an Exception. (Dealing with a click-handler on the Canvas) - After being tired of so many exceptions I clicked on continue, but i got another exception, this time within mdc.CanvasView.handle_mouse_move(). (See Stacktrace and screenshot)
After clicking "Continue" it the exception always happens again. The only thing left to do is clicking "Close". MySQL Workbench then asks to save the document. After clicking "Yes" it crashed and Vista displayed the "MySQL Workbench stopped working" window. :-(

After starting Workbench again, the same message box from http://bugs.mysql.com/bug.php?id=35598 is shown during load. After clicking Ok the file loaded, but the model just contains one table, allthough the other tables are still shown in the overview. (See screenshot 2)

When trying to delete the diagram, workbench stopped responding and froze. :-(

After a restart the same happened again, and I was still not able to delete the diagram. To reproduce I attachted the file.

I know that this is probably more than one bug, you are free to open more bugs and ask for more information.

How to repeat:
You should be able to reproduce at least the last two bugs when loading the file and trying to delete the diagram.
[27 Mar 2008 12:40] Daniel Haas
Screenshot of the Mouse-Move exception.

Attachment: mouse-move_exception.png (image/png, text), 2.47 KiB.

[27 Mar 2008 12:40] Daniel Haas
The stacktrace of the mouse-move exception.

Attachment: stacktrace_mousemove.txt (text/plain), 6.25 KiB.

[27 Mar 2008 12:41] Daniel Haas
Loading the errornouse file after the first crash.

Attachment: loading-file-after-crash.png (image/png, text), 2.47 KiB.

[27 Mar 2008 12:41] Daniel Haas
The file that shows the bug when loaded and the diagram is deleted.

Attachment: MyProject.mwb (application/octet-stream, text), 11.75 KiB.

[27 Mar 2008 12:47] Daniel Haas
Tring to add an automatically generated diagram to that file also crashes MySQL Workbench. :-(
When manually adding an empty diagram and dragging the tables into it, I got the same bec.GRTManager.flush_timers(GRTManager* ) exception from http://bugs.mysql.com/bug.php?id=35598.
(Btw I received that exception numerous times during differing tasks)

Sadly that file seems to be really busted and I have no backup and was just writing a review of MySQL Workbench. :-(
[27 Mar 2008 16:35] Miguel Solorzano
Thank you for the bug report.
[27 Mar 2008 16:41] Johannes Taxacher
this mwb file seems to be failry corrupted ... compared to the one in http://bugs.mysql.com/bug.php?id=35598
[31 Mar 2008 17:39] Johannes Taxacher
fixed (tested in SVN Rev 2893)
[8 Apr 2008 14:22] MC Brown
A note has been added to the 5.0.17 changelog: 

Deleting an existing layer on a diagram and then editing other objects on the same canvas could generate a number of exceptions, and could corrupt the Workbench file.