Bug #3555 writing false syntax in /etc/mysql/my.cnf
Submitted: 24 Apr 2004 10:00 Modified: 23 Jun 2004 17:27
Reporter: Frank Steidl Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S1 (Critical)
Version:1.0.3-alpha OS:Linux (Debian Linux 2.4.18)
Assigned to: Bugs System CPU Architecture:Any

[24 Apr 2004 10:00] Frank Steidl
Description:
diabling InnoDB in the MySQL Administrator causes an entry

 innodb=0

in the config file /etc/mysql/my.cnf

This causes the error:

 /usr/sbin/mysqld: ambiguous option '--innodb=0'

while starting mysqld.

How to repeat:
 

Suggested fix:
Right option in the config file should be

 skip-innodb
[24 Apr 2004 11:00] Ulrich Bayer
Which server version are you using? Anything above MySQL 4.0.2 should understand the syntax innodb=0.
[2 Jun 2004 5:32] Jorge del Conde
I'm using 4.1.1a, Administrator 1.0.3 and after disabling innodb I got the following:

C:\my>mysql
mysql: ERROR: unknown variable 'innodb=0'
[3 Jun 2004 2:05] Ulrich Bayer
Hi Jorge, 
Maybe you are using a binary where innodb-support is not compiled in?
Otherwise it should work - I have no problems on my computer with the same server version(4.1.1-alpha-standard)
[3 Jun 2004 2:49] Jorge del Conde
Hi Ulli

Sorry, I made a mistake in my previous email.  This bug happens in 4.0.18.

Im going to change its status back to Verified and pllease keep it that way until its fixed.

I *Do*  have InnoDB enabled and its working perfectly and even if InnoDB wasn't enabled this would still be a bug because once the changes are made to my.cnf everything else stops working while complaining about an erroneous my.cnf option.

An easy fix for this is the following:

replace the my.cnf line:
innodb=0

with
skip-innodb
[3 Jun 2004 5:31] Paul Dubois
--innodb=0 will work in MySQL 4.1.x (as will
similar options like --bdb=0 and --isam=0),
because they are treated as GET_BOOL options.
However, that's a 4.1 change.  In 4.0.x, this
will not work, because these options are not
handled as boolean options. Thus, only the
--skip-xxx forms work, and not the --xxx=0
forms. This means that MySQL Administrator
*must* write the --skip-xxx forms for servers
in the 4.0 series. It's probably safest just to
use that form always, because it works in
both 4.0.x and 4.1.x.
[4 Jun 2004 12:08] Ulrich Bayer
Hi Jorge,

You are right. I have tested it with a 4.0 server and experienced the same problem now.

Paul,
according to the manual :) GET_BOOL support was added in 4.0.2 and this is also true. The problem is that in the mysql 4.0 source the option has not been declared as GET_BOOL.
[23 Jun 2004 17:27] Ulrich Bayer
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html