Bug #35371 assigning general_log_file a variable containing file name crashing server
Submitted: 18 Mar 2008 6:46 Modified: 18 Mar 2008 12:52
Reporter: Rizwan Maredia Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Logging Severity:S2 (Serious)
Version:5.1.22 OS:Microsoft Windows
Assigned to:
Tags: general_log_file

[18 Mar 2008 6:46] Rizwan Maredia
Description:
When we assign a file name to general_log_file system variable the server crashes. Interestingly if we directly assign variable value then it gives the error that Variable 'general_log_file' can't be set to the value of 'mytest.log'.

How to repeat:
Sample Code: 

SET @log_file = "mytest.log";
SET @@global.general_log = 0;
FLUSH LOGS;
SET @@global.general_log_file = @log_file;

# the server crashes at last statement.

Suggested fix:
The server should not crash here and should give error that general_log_file can not be set to the value of 'mytest.log'.
[18 Mar 2008 7:26] Shane Bester
see also bug #31604
[18 Mar 2008 12:52] Valerii Kravchuk
This is a duplicate of bug #31604. Fixed in 5.1.23-rc.