Bug #35166 Can't create install a new database with default_storage_engine = InnoDB
Submitted: 8 Mar 2008 19:02 Modified: 12 Mar 2008 21:37
Reporter: Jonathan Purfion Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.1.23 OS:Linux (5.1.23-rc-linux-x68_64-icc-glibc23)
Assigned to: CPU Architecture:Any

[8 Mar 2008 19:02] Jonathan Purfion
I tried to install a new server using icc prebuilt binary, and a custom my.cnf.

When I tried to do ./scripts/mysql_install_db to create initial DB, i got strange message telling me : "unsupported table type: innodb" in the mySQL log.

With the help of google, I managed to find someone with the same problem, and a work-around : http://fschiettecatte.wordpress.com/2007/10/02/mysql-5122/

How to repeat:
default_storage_engine = InnoDB

in my.cnf before filling mysql.* tables with mysq_install_db script.
[12 Mar 2008 21:37] Sveta Smirnova
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Duplicate of bug #31315. See also bug #32470