Bug #35123 Crash after trying to import a DB Designer scheme
Submitted: 6 Mar 2008 17:55 Modified: 8 Apr 2008 14:31
Reporter: David KELLER Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.0.15rc OS:Microsoft Windows (XP SP2)
Assigned to: Alfredo Kengi Kojima
Tags: crash, DB Designer, import

[6 Mar 2008 17:55] David KELLER
Description:
Crash after trying to import a DB Designer scheme

How to repeat:
try to import the file in attachment
the application crash
[6 Mar 2008 20:05] Valerii Kravchuk
Thank you for a problem report. Do you use "Software rendering" version? (It does not crash for me on your model.) If no, what videocard do you have?
[6 Mar 2008 23:23] David KELLER
It's the version 5.0.14a  revision 2649
I tried with the two option with and without software rendering
the computer is a laptop ACER Aspire 9510 on XP SP2, and the graphic card a GForce Go 7600

with software rendering : "unknown exception 0xc000000d a the slot 0x78138a8c"

without software rendering : only the windows exception is displayed
[17 Mar 2008 15:49] Valerii Kravchuk
Please, try to repeat with a newer version, 5.0.15-rc, and inform about the results.
[17 Mar 2008 16:36] David KELLER
I have allways the problem
I have installed several beta versions of the workbench, you dont place anything in the windows registry that will cause a crash ?
because in this new version I dont have the choice between softaware and hardware rendering.
perhaps I can remove this entries in the registry ?

regards
David
[24 Mar 2008 16:48] Bastian Grupe
I also see the problem randomly with the latest version. A few times it works to import the file(s), a few times it doesn't.

It especially crashes quite often directly after opening workbench. Try to do some things before importing and it should work more reliably.

I haven't found a way to reliably reproduce the problem yet.
[26 Mar 2008 20:56] Valerii Kravchuk
Please, try to repeat with a newer version, 5.0.16-rc, and inform about the results.
[28 Mar 2008 14:21] Bastian Grupe
Hi,

I just installed 5.0.16 and gave it a few test runs. Good news, I cannot reproduce the Bug anymore (and I tried *really* hard)!
[28 Mar 2008 17:21] David KELLER
its ok the import now
but navigation is too slow , you have to wait more than 20 seconds after one click on a scrollbar.
the same scheme with DB Designer take less than 5 seconds. It's impossible to work with this software.
you havent done any benchmark ?
[28 Mar 2008 17:50] Johannes Taxacher
the crash is fixed (tested in SVN Rev 2888).
we're working on optimizing the canvas display.
[8 Apr 2008 14:31] MC Brown
A note has been added to the 5.0.17 changelog: 

When importing an existing DB Designer schema, Workbench could crash.