Bug #3492 grant command
Submitted: 18 Apr 2004 11:46 Modified: 18 Apr 2004 12:33
Reporter: rod luo Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:4.0.18 OS:Microsoft Windows (win2000)
Assigned to: CPU Architecture:Any

[18 Apr 2004 11:46] rod luo
Description:
GRANT ALL PRIVILEGES ON OSMS.* TO osms@localhost IDENTIFIED BY 'openipmp' WITH GRANT OPTION; 
GRANT ALL PRIVILEGES ON OSMS.* TO osms@127.0.0.1 IDENTIFIED BY 'openipmp' WITH GRANT OPTION; 
GRANT ALL PRIVILEGES ON OSMS.* TO osms@"%" IDENTIFIED BY 'openipmp' WITH GRANT OPTION; 
GRANT SHOW DATABASES ON OSMS.* TO osms@localhost IDENTIFIED BY 'openipmp' WITH GRANT OPTION; 
GRANT SHOW DATABASES ON OSMS.* TO osms@127.0.0.1 IDENTIFIED BY 'openipmp' WITH GRANT OPTION; 
GRANT SHOW DATABASES ON OSMS.* TO osms@"%" IDENTIFIED BY 'openipmp' WITH GRANT OPTION; 

First 3 commands executed ok, for the last three, i had 'wrong usage od DB GRANT and GLOBAL PRIVILEGES'. what's happening in here? why 'show databases' privilege has to be granted if the user has 'all privileges'?

How to repeat:
not sure what to fill in...
[18 Apr 2004 12:33] Paul Dubois
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.mysql.com/documentation/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Additional info:

The SHOW DATABASES privilege is an administrative
privilege, and must be granted at the global level with
ON *.*.  The first three statements use ON db_name.*,
so they grant on privileges that can be granted at the
database level.

http://dev.mysql.com/doc/mysql/en/GRANT.html
http://dev.mysql.com/doc/mysql/en/Privileges_provided.html

Please note that this is not a bug. If you're not sure
about why something works the way it does, please
ask about it on one of the mailing lists, not in the bug
system. Thanks.