Bug #348 Libmysqlclient.so.10 not found in RPM for v 4.0.12
Submitted: 30 Apr 2003 5:11 Modified: 30 Apr 2003 5:17
Reporter: Paul Andrews Email Updates:
Status: Closed Impact on me:
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:4.0.12 OS:Linux (RH Linux 8)
Assigned to: CPU Architecture:Any

[30 Apr 2003 5:11] Paul Andrews
I previously had MySQL 3.23 installed on a x86 RH 8.0 machine.

I downloaded the rpm's for version 4.

I was able to install all rpm's (including mysql-client) except for mysql-server. The error reported was that php-mysql required libmysqlclient.so.10 which could not be found.

I'm now left with a 'broken' installation of MySql.

How to repeat:

Suggested fix:
I would have assumed that the required files (present in mysql-client-3.23) would have been included in the latest rpm?
[30 Apr 2003 5:17] MySQL Verification Team
It is not there and will not be there.

current version is 12.
[30 Apr 2003 5:30] Paul Andrews
OK...your response wasn't entirely helpful.

How might I install version 4.0.12 using the rpm's given that the installation can't proceed while missing dependencies are required?

Thanks in advance.
[30 Apr 2003 6:02] Lenz Grimmer
You could install MySQL-shared from MySQL-3.23 to satisfy the dependencies. 
MySQL-shared 4.0 is not actually required to run MySQL-4.0-(server|client)
[30 Apr 2003 6:12] Paul Andrews
I tried installing the mysql-shared-3.23 but 'a newer version is currently installed'.

While I could uninstall mysql-shared-4.0.12, I wouldn't have thought it was best practice to mix versions???
[5 May 2003 9:38] Kenneth Lavrsen
I have just been trying to install MySQL 4.0 using the RPM. I was met by the same error the original poster was having.
After having read the "answer" I agree with the poster that the answer was no good and that the problem still stands. The MySQL RPMs for 4.0 are no good and cannot be installed.
Mixing up versions sounds like poison to me. There must be a proper way to solve this problem. Why have RPMs for download of they cannot be installed?
I do not understand why this bug is now in "closed" state.
For now I will have to stay with 3.X. I do not dare overruling the RPM error message and mix up versions.
[21 May 2003 23:11] Lenz Grimmer
For MySQL 4.0.13, we now also provide a new RPM "MySQL-shared-compat" 
(see http://www.mysql.com/doc/en/Linux-RPM.html) - does this resolve the problem for you?